summaryrefslogtreecommitdiff
path: root/Build/source/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2010-03-03 15:52:21 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2010-03-03 15:52:21 +0000
commitecc236ebbdd4f9d15b1513f58626dbb127963321 (patch)
tree57b4e43edfe3c9759729787a444f126d48c62020 /Build/source/Makefile.am
parent24deaaa61ff97455011a65667fd4fe7157c81b40 (diff)
do not automatically run 'make check' when cross compiling
git-svn-id: svn://tug.org/texlive/trunk@17303 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/Makefile.am')
-rw-r--r--Build/source/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Build/source/Makefile.am b/Build/source/Makefile.am
index 7257b9a539f..2569790aa76 100644
--- a/Build/source/Makefile.am
+++ b/Build/source/Makefile.am
@@ -54,6 +54,10 @@ world: all
@echo "make $@ done."
# Allow for skipping make check if needed.
+if cross_compiling
+check_target = skip
+else !cross_compiling
check_target = check
+endif !cross_compiling
skip:
.PHONY: skip