summaryrefslogtreecommitdiff
path: root/Build/source/utils/asymptote/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/utils/asymptote/configure.ac')
-rw-r--r--Build/source/utils/asymptote/configure.ac16
1 files changed, 11 insertions, 5 deletions
diff --git a/Build/source/utils/asymptote/configure.ac b/Build/source/utils/asymptote/configure.ac
index 1f36a7e8a50..e6f01473251 100644
--- a/Build/source/utils/asymptote/configure.ac
+++ b/Build/source/utils/asymptote/configure.ac
@@ -3,7 +3,7 @@
# this file.
AC_PREREQ(2)
-AC_INIT([Asymptote],[2.56],[http://sourceforge.net/projects/asymptote])
+AC_INIT([Asymptote],[2.58],[http://sourceforge.net/projects/asymptote])
VERSION=$PACKAGE_VERSION
AC_SUBST(VERSION)
m4_include([ax_pthread.m4])
@@ -138,6 +138,8 @@ AC_COMPILE_IFELSE([AC_LANG_PROGRAM(
DEFINE([<unordered_map>])),
[AC_CHECK_HEADER(ext/hash_map,,OPTIONS=$OPTIONS"-DNOHASH ")])])
+ASYGLVERSION=1.00
+
GCVERSION=8.0.4
ATOMICVERSION=7.6.10
@@ -227,7 +229,7 @@ AC_ARG_ENABLE(gc-full-debug,
INCL=$INCL" -I/usr/include/tirpc"
-if test "$OSTYPE" = "cygwin"; then
+if test "$OSTYPE" = "msdos"; then
CPPFLAGS=$CPPFLAGS" -D__MSDOS__ -I/usr/include/w32api -I/usr/include -DCALLBACK=__stdcall $INCL"
else
CPPFLAGS=$CPPFLAGS" $INCL"
@@ -236,15 +238,16 @@ fi
AC_CHECK_FUNC(getopt_long_only, AC_DEFINE(HAVE_GNU_GETOPT_H, 1,
DEFINE([GNU <getopt.h>])),
getopt="getopt getopt1",)
-
AC_SUBST(getopt)
AC_SUBST(GCVERSION)
+AC_SUBST(ASYGLVERSION)
AC_SUBST(ATOMICVERSION)
AC_SUBST(GCOPTIONS)
AC_SUBST(GCLIB)
AC_SUBST(GCPPLIB)
AC_SUBST(INCL)
AC_SUBST(OPTIONS)
+AC_SUBST(GLEW)
# Checks for libraries.
AC_SEARCH_LIBS([lgamma],[m c],,
@@ -381,7 +384,7 @@ if test "x$enable_openimageio" = "xyes"; then
fi
case "$OSTYPE" in
- cygwin)
+ msdos)
AC_CHECK_LIB([gccpp],[GC_throw_bad_alloc])
AC_CHECK_HEADER(GL/glut.h,
[AC_DEFINE(HAVE_LIBGLUT,1,
@@ -411,7 +414,10 @@ case "$OSTYPE" in
AC_CHECK_LIB([GL], [glDepthMask],
[AC_DEFINE(HAVE_LIBGL,1,
DEFINE_LIB([GL]))
- LIBS=$LIBS"-lGL glew.o "],
+ LIBS=$LIBS"-lGL "
+ GLEW="glew.o "
+ AC_CHECK_LIB([GLX],[glXGetProcAddressARB],
+ GLEW=$GLEW"-lGLX ")],
AC_MSG_NOTICE([*** Could not find libGL: will compile without OpenGL support ***]))
esac
if test "x$enable_offscreen" = "xyes"; then