summaryrefslogtreecommitdiff
path: root/Build/source/texk/xdvik/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/xdvik/tests/Makefile.am')
-rw-r--r--Build/source/texk/xdvik/tests/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/Build/source/texk/xdvik/tests/Makefile.am b/Build/source/texk/xdvik/tests/Makefile.am
new file mode 100644
index 00000000000..4fb76fddb7b
--- /dev/null
+++ b/Build/source/texk/xdvik/tests/Makefile.am
@@ -0,0 +1,35 @@
+## Makefile.am for the TeX Live subdirectory texk/xdvik/tests/
+##
+## Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+## You may freely use, modify and/or distribute this file.
+##
+include ../common.am
+
+INCLUDES = -I$(top_srcdir) -I$(top_srcdir)/gui $(common_includes)
+
+check_PROGRAMS = run_tests
+
+TESTS = $(check_PROGRAMS)
+
+run_tests_SOURCES = \
+ run_tests.c \
+ run_tests.h \
+ test_dl_list.c \
+ test_string_list.c \
+ test_string_utils.c \
+ test_util.c
+
+run_tests_DEPENDENCIES = ../libxdvi.a ../gui/libgui.a $(common_dependencies)
+
+LDADD = ../libxdvi.a ../gui/libgui.a $(common_ldadd)
+
+../libxdvi.a: $(libxdvi_dependencies)
+ cd .. && $(MAKE) $(AM_MAKEFLAGS) libxdvi.a
+
+../gui/libgui.a: $(libgui_dependencies)
+ cd ../gui && $(MAKE) $(AM_MAKEFLAGS) libgui.a
+
+## Not used
+##
+EXTRA_DIST = test1.c
+