summaryrefslogtreecommitdiff
path: root/Build/source/texk/xdv2pdf/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/xdv2pdf/configure.ac')
-rw-r--r--Build/source/texk/xdv2pdf/configure.ac10
1 files changed, 7 insertions, 3 deletions
diff --git a/Build/source/texk/xdv2pdf/configure.ac b/Build/source/texk/xdv2pdf/configure.ac
index 7eebb7787fb..ac7bf31a321 100644
--- a/Build/source/texk/xdv2pdf/configure.ac
+++ b/Build/source/texk/xdv2pdf/configure.ac
@@ -46,13 +46,17 @@ dnl Checks for library functions.
AC_CHECK_FUNCS([strspn system])
AC_SEARCH_LIBS([pow], [m])
+if test "x$enable_build" != xno || test -f config.force; then
+
dnl Check that Kpathsea supports the opentype file format.
KPSE_ADD_FLAGS([kpathsea])
-KPSE_CHECK_KPSE_FORMAT([opentype], ,
- [build=no
-KPSE_MSG_WARN([Kpathsea does not support opentype files, can not build xdv2pdf.])])
+KPSE_CHECK_KPSE_FORMAT([opentype], [],
+ [AC_MSG_ERROR([Kpathsea does not support opentype files, can not build xdv2pdf.])])
KPSE_RESTORE_FLAGS
+echo timestamp >config.force
+fi
+
fi
AM_CONDITIONAL([build], [test "x$build" = xyes])