summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/web2c/configure.ac')
-rw-r--r--Build/source/texk/web2c/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/Build/source/texk/web2c/configure.ac b/Build/source/texk/web2c/configure.ac
index 2ec55be1551..06b0f4befa9 100644
--- a/Build/source/texk/web2c/configure.ac
+++ b/Build/source/texk/web2c/configure.ac
@@ -202,6 +202,8 @@ AM_CONDITIONAL([MP], [test "x$enable_mp" != xno])
AM_CONDITIONAL([WEB], [test "x$enable_web_progs" != xno])
+AM_CONDITIONAL([SYNCTEX], [test "x$enable_synctex" != xno])
+
AS_IF([test "x$enable_ptex:$enable_eptex" = xno:no],
[enable_pweb_progs=no],
[enable_pweb_progs=$enable_web_progs])
@@ -383,6 +385,12 @@ AC_CONFIG_FILES([tangle-sh], [chmod +x tangle-sh])
AC_CONFIG_FILES([ctangleboot-sh], [chmod +x ctangleboot-sh])
AC_CONFIG_FILES([silent-sh], [chmod +x silent-sh])
+m4_define([synctex_version], m4_chomp(m4_include([synctexdir/synctex_parser_version.txt]))[.0])
+AC_SUBST([SYNCTEXVERSION], [synctex_version])
+KPSE_LT_VERSION([synctex])
+
+AC_CONFIG_FILES([synctexdir/synctex.pc])
+
dnl The subdirectory web2c must be configured for the build system.
KPSE_NATIVE_SUBDIRS([web2c])