summaryrefslogtreecommitdiff
path: root/Build/source/texk/ps2pk/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/ps2pk/configure.ac')
-rw-r--r--Build/source/texk/ps2pk/configure.ac46
1 files changed, 46 insertions, 0 deletions
diff --git a/Build/source/texk/ps2pk/configure.ac b/Build/source/texk/ps2pk/configure.ac
new file mode 100644
index 00000000000..b4f7fbe1bfb
--- /dev/null
+++ b/Build/source/texk/ps2pk/configure.ac
@@ -0,0 +1,46 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl Copyright 2009-2016 Peter Breitenlohner <tex-live@tug.org>
+dnl
+dnl This file is free software; the copyright holder
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+dnl
+AC_INIT([ps2pkm (TeX Live)], [1.8], [tex-k@tug.org])
+AC_PREREQ([2.65])
+AC_CONFIG_SRCDIR([arith.c])
+AC_CONFIG_AUX_DIR([../../build-aux])
+AC_CONFIG_MACRO_DIR([../../m4])
+
+dnl Common code for all programs using libkpathsea.
+KPSE_COMMON([ps2pkm], [no-define])
+
+AC_SEARCH_LIBS([pow], [m])
+
+dnl Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([fcntl.h])
+
+dnl Checks for types.
+AC_TYPE_INT32_T
+AC_TYPE_INTPTR_T
+AC_TYPE_UINT32_T
+
+dnl Checks for library functions.
+AC_FUNC_VPRINTF
+AC_CHECK_FUNCS([memset])
+
+AC_CONFIG_HEADERS([c-auto.h:c-auto.in])
+
+m4_include([../../version.ac])[] dnl define tex_live_version
+AC_DEFINE([TL_VERSION], ["TeX Live tex_live_version()"],
+ [Define to the current TeX Live version string.])
+
+dnl For tests
+AC_CHECK_PROGS([KPSEWHICH], [kpsewhich], [false])
+
+KPSE_KPATHSEA_FLAGS
+
+AC_CONFIG_FILES([Makefile])
+
+AC_OUTPUT