summaryrefslogtreecommitdiff
path: root/Build/source/texk/kpathsea/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/kpathsea/Makefile.am')
-rw-r--r--Build/source/texk/kpathsea/Makefile.am34
1 files changed, 1 insertions, 33 deletions
diff --git a/Build/source/texk/kpathsea/Makefile.am b/Build/source/texk/kpathsea/Makefile.am
index e4ba90f0335..ebb2c5f2cc8 100644
--- a/Build/source/texk/kpathsea/Makefile.am
+++ b/Build/source/texk/kpathsea/Makefile.am
@@ -1,7 +1,7 @@
## $Id$
## Makefile.am for the TeX Live subdirectory texk/kpathsea/
##
-## Copyright 2017-2019 Karl Berry <tex-live@tug.org>
+## Copyright 2015-2019 Karl Berry <tex-live@tug.org>
## Copyright 2009-2015 Peter Breitenlohner <tex-live@tug.org>
## You may freely use, modify and/or distribute this file.
@@ -251,21 +251,8 @@ xdirtest_LDADD = libkpathsea.la
## The scripts and their data
web2cdir = $(datarootdir)/texmf-dist/web2c
-dist_noinst_SCRIPTS = mktexlsr mktexmf mktexpk mktextfm
-
dist_noinst_DATA = texmf.cnf
-install-exec-local: installdirs-am
-if !WIN32
- @for f in $(dist_noinst_SCRIPTS); do \
- if grep "original $$f --" "$(DESTDIR)$(bindir)/$$f" >/dev/null 2>&1 \
- || test ! -r "$(DESTDIR)$(bindir)/$$f"; then \
- echo " $(INSTALL_SCRIPT) '$(srcdir)/$$f' '$(DESTDIR)$(bindir)/$$f'"; \
- $(INSTALL_SCRIPT) "$(srcdir)/$$f" "$(DESTDIR)$(bindir)/$$f"; \
- else :; fi; \
- done
-endif !WIN32
-
install-data-local: installdirs-am
$(MKDIR_P) '$(DESTDIR)$(web2cdir)'
@for f in $(dist_noinst_DATA); do \
@@ -277,14 +264,6 @@ install-data-local: installdirs-am
done
uninstall-local:
-if !WIN32
- @for f in $(dist_noinst_SCRIPTS); do \
- if grep "original $$f --" "$(DESTDIR)$(bindir)/$$f" >/dev/null 2>&1; then \
- echo " rm -f '$(DESTDIR)$(bindir)/$$f'"; \
- rm -f "$(DESTDIR)$(bindir)/$$f"; \
- else :; fi; \
- done
-endif !WIN32
@for f in $(dist_noinst_DATA); do \
if grep "original $$f --" "$(DESTDIR)$(web2cdir)/$$f" >/dev/null 2>&1; then \
echo " rm -f '$(DESTDIR)$(web2cdir)/$$f'"; \
@@ -292,14 +271,6 @@ endif !WIN32
else :; fi; \
done
-bin_links = mktexlsr:texhash
-
-include $(top_srcdir)/../../am/bin_links.am
-
-install-exec-hook: install-bin-links
-
-uninstall-hook: uninstall-bin-links
-
## Tests
AM_TESTS_ENVIRONMENT = LN_S='$(LN_S)'; export LN_S;
AM_TESTS_ENVIRONMENT += LT_OBJDIR='$(LT_OBJDIR)'; export LT_OBJDIR;
@@ -325,6 +296,3 @@ rebuild_target = all-am
CLEANFILES =
include $(srcdir)/../../am/rebuild.am
-
-## Not used
-EXTRA_DIST += mktex.cnf