summaryrefslogtreecommitdiff
path: root/Build/source/texk/dvipng/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/dvipng/Makefile.am')
-rw-r--r--Build/source/texk/dvipng/Makefile.am25
1 files changed, 7 insertions, 18 deletions
diff --git a/Build/source/texk/dvipng/Makefile.am b/Build/source/texk/dvipng/Makefile.am
index 33beaf436ed..5093a596ab3 100644
--- a/Build/source/texk/dvipng/Makefile.am
+++ b/Build/source/texk/dvipng/Makefile.am
@@ -29,7 +29,7 @@ dist-hook:
AM_CPPFLAGS = -I$(top_srcdir)/$(DVIPNG_TREE)
AM_CPPFLAGS += $(KPATHSEA_INCLUDES) $(FREETYPE2_INCLUDES) $(GD_INCLUDES)
-AM_CPPFLAGS += $(T1LIB_INCLUDES) $(LIBPNG_INCLUDES) $(ZLIB_INCLUDES)
+AM_CPPFLAGS += $(LIBPNG_INCLUDES) $(ZLIB_INCLUDES)
AM_CFLAGS = $(WARNING_CFLAGS)
DVIPS = dvips -Ppdf
@@ -57,25 +57,16 @@ nodist_dvipng_SOURCES = \
@DVIPNG_TREE@/special.c \
@DVIPNG_TREE@/vf.c
-if have_t1
-nodist_dvipng_SOURCES += \
- @DVIPNG_TREE@/t1.c
-endif have_t1
-
if have_ft2
nodist_dvipng_SOURCES += \
- @DVIPNG_TREE@/ft.c \
- @DVIPNG_TREE@/sfd.c
-endif have_ft2
-
-if have_ft2_or_t1
-nodist_dvipng_SOURCES += \
@DVIPNG_TREE@/enc.c \
@DVIPNG_TREE@/fontmap.c \
+ @DVIPNG_TREE@/ft.c \
+ @DVIPNG_TREE@/sfd.c \
@DVIPNG_TREE@/tfm.c
-endif have_ft2_or_t1
+endif have_ft2
-dvipng_dependencies = $(KPATHSEA_DEPEND) $(T1LIB_DEPEND) $(GD_DEPEND)
+dvipng_dependencies = $(KPATHSEA_DEPEND) $(GD_DEPEND)
$(dvipng_OBJECTS): config.force
@@ -87,7 +78,7 @@ config.force: $(dvipng_dependencies)
DISTCLEANFILES = config.force
LDADD = $(KPATHSEA_LIBS) $(GD_LIBS) $(FREETYPE2_LIBS)
-LDADD += $(T1LIB_LIBS) $(LIBPNG_LIBS) $(ZLIB_LIBS)
+LDADD += $(LIBPNG_LIBS) $(ZLIB_LIBS)
dvigif_CPPFLAGS = -DEXEPROG=\"dvipng.exe\"
nodist_dvigif_SOURCES = callexe.c
@@ -95,10 +86,8 @@ dvigif_LDADD =
## Rebuild libkpathsea
@KPATHSEA_RULE@
-## Rebuild libgd
+## Rebuild gd
@GD_RULE@
-## Rebuild libt1
-@T1LIB_RULE@
include $(srcdir)/../am/bin_links.am