summaryrefslogtreecommitdiff
path: root/Build/source/texk/detex/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/texk/detex/Makefile.am')
-rw-r--r--Build/source/texk/detex/Makefile.am19
1 files changed, 14 insertions, 5 deletions
diff --git a/Build/source/texk/detex/Makefile.am b/Build/source/texk/detex/Makefile.am
index 000ec857d59..528c9289a7d 100644
--- a/Build/source/texk/detex/Makefile.am
+++ b/Build/source/texk/detex/Makefile.am
@@ -1,17 +1,23 @@
## Makefile.am for the TeX Live subdirectory texk/detex/
##
-## Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+## Copyright (C) 2009, 2010 Peter Breitenlohner <tex-live@tug.org>
## You may freely use, modify and/or distribute this file.
##
ACLOCAL_AMFLAGS = -I ../../m4
-EXTRA_DIST = detex-2.7 detex-2.8 detex-2.8-PATCHES
+## We want to re-distribute the whole original detex source tree.
+EXTRA_DIST = $(DETEX_TREE)
+## Patches applied to the original source tree
+EXTRA_DIST += $(DETEX_TREE)-PATCHES
+
+## Prepare for switch detex-2.7 -> detex-2.8
+EXTRA_DIST += $(OTHER_TREE) $(OTHER_TREE)-PATCHES
# in case of an SVN repository
dist-hook:
rm -rf `find $(distdir) -name .svn`
-INCLUDES = $(KPATHSEA_INCLUDES)
+INCLUDES = -I$(top_srcdir)/$(DETEX_TREE) $(KPATHSEA_INCLUDES)
AM_CPPFLAGS = -DKPATHSEA -Dlint
AM_CFLAGS = $(WARNING_CFLAGS)
@@ -22,7 +28,9 @@ AM_CFLAGS = $(WARNING_CFLAGS)
bin_PROGRAMS = detex
-detex_SOURCES = detex.h detex.l
+detex_SOURCES = \
+ $(DETEX_TREE)/detex.h \
+ $(DETEX_TREE)/detex.l
LDADD = $(KPATHSEA_LIBS)
@@ -31,7 +39,8 @@ $(detex_OBJECTS): $(KPATHSEA_DEPEND)
## Rebuild libkpathsea
@KPATHSEA_RULE@
-dist_man1_MANS = detex.man
+man1_MANS = \
+ $(DETEX_TREE)/detex.man
dist_check_SCRIPTS = detex.test