summaryrefslogtreecommitdiff
path: root/Build/source/libs/xpdf/xpdf-src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/xpdf/xpdf-src/CMakeLists.txt')
-rw-r--r--Build/source/libs/xpdf/xpdf-src/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/Build/source/libs/xpdf/xpdf-src/CMakeLists.txt b/Build/source/libs/xpdf/xpdf-src/CMakeLists.txt
new file mode 100644
index 00000000000..a99cd253231
--- /dev/null
+++ b/Build/source/libs/xpdf/xpdf-src/CMakeLists.txt
@@ -0,0 +1,41 @@
+#========================================================================
+#
+# cmake-xpdf.txt
+#
+# CMake script for the Xpdf package.
+#
+# Copyright 2015 Glyph & Cog, LLC
+#
+#========================================================================
+
+cmake_minimum_required(VERSION 2.8.8)
+
+project(xpdf)
+
+include(cmake-config.txt)
+
+add_subdirectory(goo)
+add_subdirectory(fofi)
+add_subdirectory(splash)
+add_subdirectory(xpdf)
+add_subdirectory(xpdf-qt)
+
+if (NOT HAVE_FREETYPE_H)
+ message(WARNING "Couldn't find FreeType -- will not build pdftoppm, pdftopng, pdftohtml, or xpdf.")
+endif ()
+
+if (NOT PNG_FOUND)
+ message(WARNING "Couldn't find libpng -- will not build pdftopng or pdftohtml.")
+endif ()
+
+if (NOT QT4_FOUND AND NOT Qt5Widgets_FOUND)
+ message(WARNING "Couldn't find Qt4 or Qt5 -- will not build xpdf.")
+endif ()
+
+if (NOT MULTITHREADED)
+ message(WARNING "Multithreading is disabled -- will not build xpdf.")
+endif ()
+
+if (NOT USE_EXCEPTIONS)
+ message(WARNING "C++ exceptions are disabled -- will not build xpdf.")
+endif ()