summaryrefslogtreecommitdiff
path: root/Build/source/libs/harfbuzz/harfbuzz-src/src/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/libs/harfbuzz/harfbuzz-src/src/meson.build')
-rw-r--r--Build/source/libs/harfbuzz/harfbuzz-src/src/meson.build32
1 files changed, 5 insertions, 27 deletions
diff --git a/Build/source/libs/harfbuzz/harfbuzz-src/src/meson.build b/Build/source/libs/harfbuzz/harfbuzz-src/src/meson.build
index 8bfbd97b8e9..ec3b7c718c3 100644
--- a/Build/source/libs/harfbuzz/harfbuzz-src/src/meson.build
+++ b/Build/source/libs/harfbuzz/harfbuzz-src/src/meson.build
@@ -126,10 +126,11 @@ hb_base_sources = files(
'hb-ot-shape-complex-khmer.hh',
'hb-ot-shape-complex-myanmar.cc',
'hb-ot-shape-complex-myanmar.hh',
+ 'hb-ot-shape-complex-syllabic.cc',
+ 'hb-ot-shape-complex-syllabic.hh',
'hb-ot-shape-complex-thai.cc',
- 'hb-ot-shape-complex-use-table.cc',
+ 'hb-ot-shape-complex-use-table.hh',
'hb-ot-shape-complex-use.cc',
- 'hb-ot-shape-complex-use.hh',
'hb-ot-shape-complex-vowel-constraints.cc',
'hb-ot-shape-complex-vowel-constraints.hh',
'hb-ot-shape-complex.hh',
@@ -271,10 +272,8 @@ hb_subset_sources = files(
'hb-subset-input.hh',
'hb-subset-plan.cc',
'hb-subset-plan.hh',
- 'hb-subset-plan.hh',
'hb-subset.cc',
'hb-subset.hh',
- 'hb-subset.hh',
)
hb_subset_headers = files('hb-subset.h')
@@ -475,21 +474,6 @@ if get_option('tests').enabled()
endforeach
endif
- check_programs = {
- 'dump-indic-data': ['dump-indic-data.cc', 'hb-ot-shape-complex-indic-table.cc'],
- 'dump-khmer-data': ['dump-khmer-data.cc', 'hb-ot-shape-complex-indic-table.cc'],
- 'dump-myanmar-data': ['dump-myanmar-data.cc', 'hb-ot-shape-complex-indic-table.cc'],
- 'dump-use-data': ['dump-use-data.cc', 'hb-ot-shape-complex-use-table.cc'],
- }
- foreach name, source : check_programs
- executable(name, source,
- include_directories: incconfig,
- cpp_args: cpp_args,
- dependencies: libharfbuzz_dep,
- install: false,
- )
- endforeach
-
compiled_tests = {
'test-algs': ['test-algs.cc', 'hb-static.cc'],
'test-array': ['test-array.cc'],
@@ -656,14 +640,8 @@ if have_gobject
header: 'hb-gobject.h',
install: true,
extra_args: ['--cflags-begin',
- '-DHB_H',
- '-DHB_H_IN',
- '-DHB_OT_H',
- '-DHB_OT_H_IN',
- '-DHB_AAT_H',
- '-DHB_AAT_H_IN',
- '-DHB_GOBJECT_H',
- '-DHB_GOBJECT_H_IN',
+ '-DHB_NO_SINGLE_HEADER_ERROR',
+ '-DHAVE_GOBJECT',
'-DHB_EXTERN=',
'--cflags-end'])
endif