summaryrefslogtreecommitdiff
path: root/Build/source/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Build/source/doc/Makefile.am')
-rw-r--r--Build/source/doc/Makefile.am29
1 files changed, 19 insertions, 10 deletions
diff --git a/Build/source/doc/Makefile.am b/Build/source/doc/Makefile.am
index a9caaf8b59b..d968fb66dcf 100644
--- a/Build/source/doc/Makefile.am
+++ b/Build/source/doc/Makefile.am
@@ -1,5 +1,6 @@
## Makefile.am for the TeX Live subdirectory ./doc/
##
+## Copyright 2015-2018 Karl Berry <tex-live@tug.org>
## Copyright 2013-2015 Peter Breitenlohner <tex-live@tug.org>
## You may freely use, modify and/or distribute this file.
##
@@ -53,27 +54,35 @@ pod2texi_args = \
# The \@... in the replacements are escaping the @ in a Perl
# double-quote context, i.e., not an array.
#
-update_node_bad = ref{tlmgr update [option]... [pkg]...,
-update_node_bad2 = ref{tlmgr update,
-update_node_good = ref{tlmgr update [\@emph{option}]... [\@emph{pkg}]...,
+update_node_bad = ref{tlmgr update [option...] [pkg...],
+update_node_good = ref{tlmgr update [\@emph{option}...] [\@emph{pkg}...],
#
-restore_node_bad = ref{tlmgr restore,
-restore_node_good = ref{tlmgr restore [--backupdir \@emph{dir}] [--all | \@emph{pkg} [\@emph{rev}]],
+update_node_bad2 = [option...] [pkg...], update
+update_node_good2 = [\@emph{option}...] [@emph{pkg}...], update
#
-install_node_bad = ref{tlmgr install [option]... pkg...,
-install_node_good = ref{tlmgr install [\@emph{option}]... \@emph{pkg}...,
+remove_node_bad = ref{tlmgr remove [option...] pkg...,
+remove_node_good = ref{tlmgr remove [\@emph{option}...] \@emph{pkg}...,
+#
+install_node_bad = ref{tlmgr install [option...] pkg...,
+install_node_good = ref{tlmgr install [\@emph{option}...] \@emph{pkg}...,
# we don't actually use the (autogenerated) -incl.texi file,
-# but it makes for a convenient target. Copy the scripts into the build dir.
+# but it makes for a convenient target.
+#
+# First make symlinks in build dir:
+# ln -s .../tlmgr.pl .../Build/source/Work/doc
+# ln -s .../install-tl .../Build/source/Work/doc
$(mydoc)-incl.texi: install-tl tlmgr.pl
$(pod2texi) -o $@ --subdir=$(mydoc)-incl $(pod2texi_args) $^
cp $(mydoc)-incl/tlmgr.texi $(mydoc)-incl/tlmgr.texi.orig
perl -pi \
-e 's/\Q$(update_node_bad)\E/$(update_node_good)/' \
- -e ';s/\Q$(update_node_bad2)\E/$(update_node_good),/' \
+ -e ';s/\Q$(update_node_bad2)\E/$(update_node_good2),/' \
-e ';' \
- -e 's/\Q$(restore_node_bad)\E/$(restore_node_good)/' \
+ -e 's/\Q$(remove_node_bad)\E/$(remove_node_good)/' \
-e ';' \
-e 's/\Q$(install_node_bad)\E/$(install_node_good)/' \
$(mydoc)-incl/tlmgr.texi
+ cp $(mydoc)-incl/tlmgr.texi $(srcdir)/$(mydoc)-incl/
+ cp $(mydoc)-incl/install-tl.texi $(srcdir)/$(mydoc)-incl/
.PHONY: $(mydoc)-incl.texi