summaryrefslogtreecommitdiff
path: root/Build/source/utils/m-tx/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2012-10-04 11:49:07 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2012-10-04 11:49:07 +0000
commitbb68138f5309f867ed9b80a6850794104832254f (patch)
treed8c199743baba187e9dde17f02997385e4e433b4 /Build/source/utils/m-tx/Makefile.am
parentd9fb534f18ff3816d0d7152a10e56f5fcd3821f7 (diff)
m-tx: More check value returned by malloc()
git-svn-id: svn://tug.org/texlive/trunk@27877 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/utils/m-tx/Makefile.am')
-rw-r--r--Build/source/utils/m-tx/Makefile.am14
1 files changed, 3 insertions, 11 deletions
diff --git a/Build/source/utils/m-tx/Makefile.am b/Build/source/utils/m-tx/Makefile.am
index 7cf23755866..4f1f2e466c6 100644
--- a/Build/source/utils/m-tx/Makefile.am
+++ b/Build/source/utils/m-tx/Makefile.am
@@ -14,14 +14,11 @@ EXTRA_DIST += $(MTX_TREE)-PATCHES
dist-hook:
rm -rf `find $(distdir) -name .svn`
-INCLUDES = -I$(srcdir)/$(MTX_TREE)/libp2c
-AM_CPPFLAGS = -DNO_DECLARE_MALLOC
+AM_CPPFLAGS = -I$(srcdir)/$(MTX_TREE)/libp2c -DNO_DECLARE_MALLOC
AM_CFLAGS = #$(WARNING_CFLAGS)
bin_PROGRAMS = prepmx
-## prepmx_SOURCES = config.h
-
prepmx_SOURCES = \
$(MTX_TREE)/analyze.c \
$(MTX_TREE)/analyze.h \
@@ -33,6 +30,7 @@ prepmx_SOURCES = \
$(MTX_TREE)/files.h \
$(MTX_TREE)/globals.c \
$(MTX_TREE)/globals.h \
+ $(MTX_TREE)/libp2c/p2c.h \
$(MTX_TREE)/lyrics.c \
$(MTX_TREE)/lyrics.h \
$(MTX_TREE)/mtx.c \
@@ -54,13 +52,7 @@ prepmx_SOURCES = \
$(MTX_TREE)/utility.c \
$(MTX_TREE)/utility.h
-LDADD = libp2c.a
-
-noinst_LIBRARIES = libp2c.a
-
-libp2c_a_SOURCES = \
- $(MTX_TREE)/libp2c/p2c.h \
- $(MTX_TREE)/libp2c/p2clib.c
+## We can not use $(MTX_TREE)/libp2c/p2clib.c (multiple definitions).
lua_scripts = m-tx