summaryrefslogtreecommitdiff
path: root/Build/source/utils/biber/configure.ac
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2011-03-15 23:38:48 +0000
committerKarl Berry <karl@freefriends.org>2011-03-15 23:38:48 +0000
commit48f5ba0907a03b39a510376740b5a647a486cab7 (patch)
treec51fa14913f6c2ed494fe77cb62620c3e3aa0285 /Build/source/utils/biber/configure.ac
parentef44f6e3d8f6ca785d5bf019fc4046d406bc82e2 (diff)
biber 0.8.3, with more binaries and revamped mechanism in Build
git-svn-id: svn://tug.org/texlive/trunk@21726 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/utils/biber/configure.ac')
-rw-r--r--Build/source/utils/biber/configure.ac27
1 files changed, 18 insertions, 9 deletions
diff --git a/Build/source/utils/biber/configure.ac b/Build/source/utils/biber/configure.ac
index 3b7da920ce6..f2ea05ad55f 100644
--- a/Build/source/utils/biber/configure.ac
+++ b/Build/source/utils/biber/configure.ac
@@ -8,15 +8,18 @@ dnl with or without modifications, as long as this notice is preserved.
dnl
AC_INIT([Biber], [TeX Live], [tex-k@tug.org])
AC_PREREQ([2.65])
-AC_CONFIG_SRCDIR([biber.i386-linux])
+AC_CONFIG_SRCDIR([TeXLive/TLConfig.pm])
AC_CONFIG_AUX_DIR([../../build-aux])
AC_CONFIG_MACRO_DIR([../../m4])
AM_INIT_AUTOMAKE([foreign])
AM_MAINTAINER_MODE
-dnl Checks for programs.
-AC_PROG_INSTALL
+# System type for cross-compilation.
+AC_CANONICAL_HOST
+AC_EXEEXT
+
+# Checks for programs.
AC_PROG_MAKE_SET
AC_MSG_CHECKING([for TeX Live platform name])
@@ -29,16 +32,22 @@ TL_platform=`perl -e '
use TeXLive::TLUtils;
print TeXLive::TLUtils::platform();'`
#
-AC_MSG_RESULT($TL_platform)
+AC_MSG_RESULT([$TL_platform])
if test -z "$TL_platform"; then
AC_MSG_ERROR("cannot determine TeX Live platform name")
fi
-#
-AC_SUBST([TL_PLATFORM], [$TL_platform])
-# Check if we have an executable for the current platform.
-AM_CONDITIONAL([TL_HAVE_BIBER_BINARY],
- [test -r "$srcdir/biber.$TL_platform"])
+biber_exe=$srcdir/bin/$TL_platform/biber$ac_exeext
+AC_MSG_CHECKING([for executable in $biber_exe])
+if test -r "$biber_exe"; then
+ AC_SUBST([BIBER_EXE], [$biber_exe])
+ AC_MSG_RESULT([yes])
+else
+ AC_MSG_RESULT([no])
+fi
+
+# Check for having an executable for the needed platform.
+AM_CONDITIONAL([TL_HAVE_BIBER_BINARY], [test -r "$biber_exe"])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT