summaryrefslogtreecommitdiff
path: root/Build/source/utils/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2013-07-07 14:29:53 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2013-07-07 14:29:53 +0000
commit0df6dd4d8aea6edc733de81fb7eec115ea59a36e (patch)
treee2f7056cb53c58c8ef5779450ac468091b2bd86d /Build/source/utils/Makefile.am
parent3675a91dd83af3eaa1c1a12e91af1e6c86f710f8 (diff)
build system: additional Makefile fragments
better handling of dependencies for highly parallel make git-svn-id: svn://tug.org/texlive/trunk@31127 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/utils/Makefile.am')
-rw-r--r--Build/source/utils/Makefile.am53
1 files changed, 8 insertions, 45 deletions
diff --git a/Build/source/utils/Makefile.am b/Build/source/utils/Makefile.am
index 6722cf7cd91..dd59231fc64 100644
--- a/Build/source/utils/Makefile.am
+++ b/Build/source/utils/Makefile.am
@@ -1,14 +1,14 @@
## Makefile.am for the TeX Live subdirectory utils/
##
-## Copyright (C) 2009, 2012 Peter Breitenlohner <tex-live@tug.org>
+## Copyright (C) 2009-2013 Peter Breitenlohner <tex-live@tug.org>
## You may freely use, modify and/or distribute this file.
##
## Use 'aclocal --force' (for "computed m4_sinclude")
##
ACLOCAL_AMFLAGS = -I ../m4 --force
-SUBDIRS = . $(SUBUTILS)
-DIST_SUBDIRS = $(DIST_SUBUTILS)
+SUBDIRS = . $(MAKE_SUBDIRS)
+DIST_SUBDIRS = $(CONF_SUBDIRS)
cf_silent = $(cf_silent_@AM_V@)
cf_silent_ = $(cf_silent_@AM_DEFAULT_V@)
@@ -19,47 +19,10 @@ cf_silent_1 =
dist-hook:
rm -rf `find $(distdir) -name .svn`
-CONFIG_AUX = ../subsubdir-conf.cmd
-
-all-local: subutils
-
-.PHONY: subutils
-# We must configure all utils subdirs since 'make dist' needs the Makefile.
-# For those not required for the current set of configure options
-# we append '--disable-build' so they can skip tests that would
-# fail because, e.g., some required libraries were not built.
-#
-# Sequentially configure and optionally build all utils subdirs;
-# code inspired by automake's way to handle recursive targets.
-subutils: $(CONFIG_AUX)
- @fail= failcom='exit 1'; \
- for f in x $$MAKEFLAGS; do \
- case $$f in \
- *=* | --[!k]*);; \
- *k*) failcom='fail=yes';; \
- esac; \
- done; \
- list='$(DIST_SUBUTILS)'; for subutils in $$list; do \
- if test ! -f $$subutils/Makefile; then \
- test -d $$subutils || $(MKDIR_P) $$subutils; \
- cmd=`cat $(CONFIG_AUX) | sed "s,auxdir/auxsub,utils/$$subutils,g"`; \
- case " $(SUBUTILS) " in \
- *" $$subutils "*) skip=;; \
- *) skip=' --disable-build';; \
- esac; \
- (cd $$subutils && echo "=== configuring in $$subutils (`pwd`)" && \
- if $(AM_V_P); then echo "make: running $(SHELL) $$cmd$$skip"; fi && \
- CONFIG_SHELL=$(SHELL) && export CONFIG_SHELL && \
- eval $(SHELL) $$cmd$$skip $(cf_silent) || \
- { echo "=== configuring in $$subutils failed"; exit 1; }) && \
- if test "x$$skip" = x; then \
- echo "Making all in $$subutils" && \
- (cd $$subutils && $(MAKE) $(AM_MAKEFLAGS) all); \
- fi || eval $$failcom; \
- fi; \
- done; test -z "$$fail"
+## Configure and build subdirs.
+##
+recurse_this = utils/
+recurse_top = ../
-../subsubdir-conf.cmd:
- @echo "configure in ../auxdir/auxsub failed to create the file $@"
- exit 1
+include $(srcdir)/../am/recurse.am