summaryrefslogtreecommitdiff
path: root/Build/source/texk/xdvipdfmx/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-11-16 09:51:30 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-11-16 09:51:30 +0000
commit09950a732cfa76559d18b3540d69bf7eed235171 (patch)
tree00e395f5458e8c3d6904d313d1d513fc9d1dabfb /Build/source/texk/xdvipdfmx/configure.ac
parent6d04c5f72978b866477b0608d68285045337b061 (diff)
build system: --enable-libtool-hack to prvent linking with dependency_libs
git-svn-id: svn://tug.org/texlive/trunk@16027 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/xdvipdfmx/configure.ac')
-rw-r--r--Build/source/texk/xdvipdfmx/configure.ac14
1 files changed, 8 insertions, 6 deletions
diff --git a/Build/source/texk/xdvipdfmx/configure.ac b/Build/source/texk/xdvipdfmx/configure.ac
index 121ded467a9..bee1fd6e569 100644
--- a/Build/source/texk/xdvipdfmx/configure.ac
+++ b/Build/source/texk/xdvipdfmx/configure.ac
@@ -17,6 +17,8 @@ KPSE_COMMON([xdvipdfmx])
AC_CONFIG_HEADERS([config.h])
+KPSE_LT_HACK
+
dnl Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS([stdint.h inttypes.h sys/types.h])
@@ -83,24 +85,24 @@ fi
KPSE_CHECK_FRAMEWORK([ApplicationServices], [ATSFontRef fontRef])
KPSE_FONTCONFIG_FLAGS
if test "x$kpse_cv_have_ApplicationServices" = xyes; then
- build=yes
- AC_DEFINE([XETEX_MAC], 1, [Define if part of a teTeX/TeX Live build for Mac OS X.])
+ can_build=yes
+ AC_DEFINE([XETEX_MAC], 1, [Define if part of a TeX Live build for Mac OS X.])
else
KPSE_ADD_FLAGS([fontconfig])
CHO_CHECK_LIBFONTCONFIG
KPSE_RESTORE_FLAGS
- build=$cho_cv_have_fontconfig
+ can_build=$cho_cv_have_fontconfig
fi
-if test "x$build" = xyes; then
- AC_DEFINE([XETEX], 1, [Define if part of a teTeX/TeX Live build.])
+if test "x$can_build" = xyes; then
+ AC_DEFINE([XETEX], 1, [Define if part of a TeX Live build.])
else
AC_MSG_ERROR([fontconfig library or ApplicationServices framework not found.
This version of xdvipdfmx requires either ApplicationServices (on Mac OS X)
or the fontconfig library (on other platforms) to be available, otherwise it
cannot support XeTeX output using standard system-installed fonts.])
fi
-AM_CONDITIONAL([build], [test "x$build" = xyes])
+AM_CONDITIONAL([build], [test "x$can_build" = xyes])
AM_CONDITIONAL([build_MacOsX], [test "x$kpse_cv_have_ApplicationServices" = xyes])
AC_CONFIG_FILES([Makefile src/Makefile])