summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/otps/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-05-29 11:31:46 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-05-29 11:31:46 +0000
commit030c7d295204835a00a4084ca59b1f712afb39fe (patch)
treecaca6301bdaf276428e3cb513231f92407a1299c /Build/source/texk/web2c/otps/Makefile.am
parentf17356b770f3dd2fa28b8d5632d20e0e0f5542d7 (diff)
revive Web2C versions of omega font utils
some cleanup git-svn-id: svn://tug.org/texlive/trunk@13517 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/web2c/otps/Makefile.am')
-rw-r--r--Build/source/texk/web2c/otps/Makefile.am17
1 files changed, 10 insertions, 7 deletions
diff --git a/Build/source/texk/web2c/otps/Makefile.am b/Build/source/texk/web2c/otps/Makefile.am
index 31ff842c178..5ecf9e13710 100644
--- a/Build/source/texk/web2c/otps/Makefile.am
+++ b/Build/source/texk/web2c/otps/Makefile.am
@@ -19,11 +19,18 @@ $(proglib): $(KPATHSEA_DEPEND) ${top_srcdir}/lib/*.c
## Rebuild libkpathsea
@KPATHSEA_RULE@
-bin_PROGRAMS = otp2ocp outocp
+otps_programs = otp2ocp outocp
+otps_scripts = mkocp mkofm
noinst_HEADERS = otp.h routines.h yystype.h
-dist_bin_SCRIPTS = mkocp mkofm
+if OTANGLE
+bin_PROGRAMS = $(otps_programs)
+bin_SCRIPTS = $(otps_scripts)
+endif OTANGLE
+EXTRA_PROGRAMS = $(otps_programs)
+
+EXTRA_DIST = $(otps_scripts)
otp2ocp_SOURCES = \
otp-parser.y \
@@ -42,9 +49,5 @@ outocp_LDADD = $(proglib) $(KPATHSEA_LIBS)
## Not used
##
-EXTRA_DIST = bugs.txt
+EXTRA_DIST += bugs.txt
-## Eventually delete these files
-##
-EXTRA_DIST += \
- Makefile.in.orig