summaryrefslogtreecommitdiff
path: root/Build/source/texk/web2c/omegafonts/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-05-29 11:31:46 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-05-29 11:31:46 +0000
commit030c7d295204835a00a4084ca59b1f712afb39fe (patch)
treecaca6301bdaf276428e3cb513231f92407a1299c /Build/source/texk/web2c/omegafonts/Makefile.am
parentf17356b770f3dd2fa28b8d5632d20e0e0f5542d7 (diff)
revive Web2C versions of omega font utils
some cleanup git-svn-id: svn://tug.org/texlive/trunk@13517 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/web2c/omegafonts/Makefile.am')
-rw-r--r--Build/source/texk/web2c/omegafonts/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Build/source/texk/web2c/omegafonts/Makefile.am b/Build/source/texk/web2c/omegafonts/Makefile.am
index 479fcf3c9a8..d8b553a639a 100644
--- a/Build/source/texk/web2c/omegafonts/Makefile.am
+++ b/Build/source/texk/web2c/omegafonts/Makefile.am
@@ -19,7 +19,10 @@ $(proglib): $(KPATHSEA_DEPEND) ${top_srcdir}/lib/*.c
## Rebuild libkpathsea
@KPATHSEA_RULE@
+if OTANGLE
bin_PROGRAMS = omfonts
+endif OTANGLE
+EXTRA_PROGRAMS = omfonts
omfonts_SOURCES = \
char_routines.c \
@@ -62,15 +65,16 @@ DISTCLEANFILES = pl-parser.output
linked_programs = ofm2opl opl2ofm ovf2ovp ovp2ovf
+if OTANGLE
install-exec-hook:
cd $(DESTDIR)$(bindir) && \
for f in $(linked_programs); do \
rm -f $$f$(EXEEXT) && \
$(LN_S) omfonts$(EXEEXT) $$f$(EXEEXT) || exit 1; \
done
-
unistall-hook:
for f in $(linked_programs); do \
rm -f $(DESTDIR)$(bindir)/$$f$(EXEEXT); \
done
+endif OTANGLE