summaryrefslogtreecommitdiff
path: root/Build/source/texk/ttfdump/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-03-20 10:15:32 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-03-20 10:15:32 +0000
commitd7f8ab6ea1a683492b985013a541ab11e33b9f73 (patch)
treea8b719cba4c45e2e308b53ebbd0ebb313a7cbf36 /Build/source/texk/ttfdump/configure.ac
parent9d502c516fe61658f540e6b98621632b91deb53c (diff)
new build system
git-svn-id: svn://tug.org/texlive/trunk@12458 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/ttfdump/configure.ac')
-rw-r--r--Build/source/texk/ttfdump/configure.ac38
1 files changed, 38 insertions, 0 deletions
diff --git a/Build/source/texk/ttfdump/configure.ac b/Build/source/texk/ttfdump/configure.ac
new file mode 100644
index 00000000000..81db87c33db
--- /dev/null
+++ b/Build/source/texk/ttfdump/configure.ac
@@ -0,0 +1,38 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl Copyright (C) 2009 Peter Breitenlohner <tex-live@tug.org>
+dnl
+dnl This file is free software; the copyright holder
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+dnl
+AC_INIT([ttfdump for TeX Live], [0.5.5], [tex-k@tug.org])
+AC_PREREQ([2.63])
+AC_CONFIG_SRCDIR([include/ttf.h])
+AC_CONFIG_AUX_DIR([../../build-aux])
+AC_CONFIG_MACRO_DIR([../../m4])
+
+dnl Common code for all programs using libkpathsea.
+KPSE_COMMON([ttfdump])
+
+dnl Checks for header files.
+AC_HEADER_STDC
+
+dnl Checks for typedefs, structures, and compiler characteristics.
+
+AC_C_BIGENDIAN
+AC_CHECK_SIZEOF([int])
+AC_CHECK_SIZEOF([long])
+AC_CHECK_SIZEOF([long long])
+AC_C_INLINE
+
+dnl Checks for library functions.
+AC_CHECK_FUNCS([strstr])
+
+AC_CONFIG_HEADERS([config.h])
+
+KPSE_KPATHSEA_FLAGS
+
+AC_CONFIG_FILES([Makefile])
+
+AC_OUTPUT