summaryrefslogtreecommitdiff
path: root/Build/source/texk/psutils/configure.ac
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2021-02-25 19:22:25 +0000
committerKarl Berry <karl@freefriends.org>2021-02-25 19:22:25 +0000
commitad547a6b5986815fda458221149728d9d9ab1d87 (patch)
tree16296910eb3eca724371474ea9aea3994dc69614 /Build/source/texk/psutils/configure.ac
parent947b43de3dd21d58ccc2ffadefc4441ea1c2a813 (diff)
restore Build,TODO from r57911
git-svn-id: svn://tug.org/texlive/trunk@57915 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/psutils/configure.ac')
-rw-r--r--Build/source/texk/psutils/configure.ac39
1 files changed, 39 insertions, 0 deletions
diff --git a/Build/source/texk/psutils/configure.ac b/Build/source/texk/psutils/configure.ac
new file mode 100644
index 00000000000..fd8554c0c0b
--- /dev/null
+++ b/Build/source/texk/psutils/configure.ac
@@ -0,0 +1,39 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl Copyright (C) 2009-2014 Peter Breitenlohner <tex-live@tug.org>
+dnl
+dnl This file is free software; the copyright holder
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+dnl
+m4_include([version.ac])[] dnl define psutils_version
+AC_INIT([psutils (TeX Live)], psutils_version, [tex-k@tug.org])
+AC_PREREQ([2.65])
+AC_CONFIG_SRCDIR([psutils-src/psutil.c])
+AC_CONFIG_AUX_DIR([../../build-aux])
+AC_CONFIG_MACRO_DIR([../../m4])
+
+KPSE_COMMON([psutils])
+
+AC_CONFIG_HEADERS([config.h])
+
+AH_TOP([#ifndef _PSUTILS_CONFIG_H
+#define _PSUTILS_CONFIG_H 1])
+AH_BOTTOM([#include <texlive.h>
+
+#endif /* _PSUTILS_CONFIG_H */])
+
+KPSE_KPATHSEA_FLAGS
+KPSE_LIBPAPER_FLAGS
+
+KPSE_COND_WIN32_WRAP
+
+AC_SUBST([PSUTILS_TREE], [psutils-src])
+
+AC_CONFIG_FILES([Makefile])
+
+AC_CONFIG_LINKS([extractres.pl:psutils-src/extractres])
+AC_CONFIG_LINKS([includeres.pl:psutils-src/extractres])
+AC_CONFIG_LINKS([psjoin.pl:psutils-src/psjoin])
+
+AC_OUTPUT