summaryrefslogtreecommitdiff
path: root/Build/source/texk/kpathsea/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2009-07-02 13:04:27 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2009-07-02 13:04:27 +0000
commiteadb78140f106e59a3d067eb591e6a5e0820a3c1 (patch)
tree449feae3ab6f96b6e39cca2a755872fa15e76b75 /Build/source/texk/kpathsea/Makefile.am
parentf7f121442e1179177b28881dbcc8488a0586d071 (diff)
rule to build kpathsea/kpathsea.h
git-svn-id: svn://tug.org/texlive/trunk@14070 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/kpathsea/Makefile.am')
-rw-r--r--Build/source/texk/kpathsea/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/Build/source/texk/kpathsea/Makefile.am b/Build/source/texk/kpathsea/Makefile.am
index 2643ac009a4..7064ea63e6b 100644
--- a/Build/source/texk/kpathsea/Makefile.am
+++ b/Build/source/texk/kpathsea/Makefile.am
@@ -221,12 +221,12 @@ kpathsea.h: Makefile paths.h
echo '#include <kpathsea/c-auto.h>' >>$@
echo '#include <kpathsea/paths.h>' >>$@
(cd $(srcdir) && ls -1 *.h) \
- | grep -v 'config\.h' \
- | grep -v 'paths\.h' \
- | grep -v 'kpathsea\.h' \
- | grep -v 'mingw32\.h' \
- | grep -v 'win32lib\.h' \
- | sed -e 's,^,#include <kpathsea/,' -e s',$$,>,' >>$@
+ | sed -e '/^config\.h/d' \
+ -e '/^paths\.h/d' \
+ -e '/^kpathsea\.h/d' \
+ -e '/^mingw32\.h/d' \
+ -e '/^win32lib\.h/d' \
+ -e 's,^,#include <kpathsea/,' -e s',$$,>,' >>$@
DISTCLEANFILES = paths.h stamp-paths kpathsea.h