summaryrefslogtreecommitdiff
path: root/Build/source/texk/kpathsea/Makefile.am
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2012-07-13 05:55:26 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2012-07-13 05:55:26 +0000
commita1972ea07466ac3bd604731ea28a25d12d1b00f5 (patch)
tree39d170bf073f9c11c26d515d3675fd652da6127e /Build/source/texk/kpathsea/Makefile.am
parent7ed10038afbe1c706d74d769a3f87a18e84075fc (diff)
kpathsea: Reduce TL vs W32TeX diffs:
Skip compilation of of xf{seek,tell}o.c for MSVC Drop prototypes for xf{seek,tell}o() in win32lib.h, they are in lib.h git-svn-id: svn://tug.org/texlive/trunk@27020 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/kpathsea/Makefile.am')
-rw-r--r--Build/source/texk/kpathsea/Makefile.am19
1 files changed, 13 insertions, 6 deletions
diff --git a/Build/source/texk/kpathsea/Makefile.am b/Build/source/texk/kpathsea/Makefile.am
index a80fc85b9b0..f667820aa95 100644
--- a/Build/source/texk/kpathsea/Makefile.am
+++ b/Build/source/texk/kpathsea/Makefile.am
@@ -76,9 +76,7 @@ libkpathsea_la_SOURCES = \
xdirname.c \
xfopen.c \
xfseek.c \
- xfseeko.c \
xftell.c \
- xftello.c \
xgetcwd.c \
xmalloc.c \
xopendir.c \
@@ -89,13 +87,22 @@ libkpathsea_la_SOURCES = \
if WIN32
if MINGW32
-libkpathsea_la_SOURCES += mingw32.c
+libkpathsea_la_SOURCES += \
+ mingw32.c \
+ xfseeko.c \
+ xftello.c
else !MINGW32
-libkpathsea_la_SOURCES += win32lib.c
+libkpathsea_la_SOURCES += \
+ win32lib.c
endif !MINGW32
-libkpathsea_la_SOURCES += knj.c
+libkpathsea_la_SOURCES += \
+ knj.c
SUBDIRS += win32
-endif WIN32
+else !WIN32
+libkpathsea_la_SOURCES += \
+ xfseeko.c \
+ xftello.c
+endif !WIN32
$(libkpathsea_la_OBJECTS): paths.h kpathsea.h