summaryrefslogtreecommitdiff
path: root/Build/source/texk/detex/Makefile.am
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2021-02-25 19:22:25 +0000
committerKarl Berry <karl@freefriends.org>2021-02-25 19:22:25 +0000
commitad547a6b5986815fda458221149728d9d9ab1d87 (patch)
tree16296910eb3eca724371474ea9aea3994dc69614 /Build/source/texk/detex/Makefile.am
parent947b43de3dd21d58ccc2ffadefc4441ea1c2a813 (diff)
restore Build,TODO from r57911
git-svn-id: svn://tug.org/texlive/trunk@57915 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/texk/detex/Makefile.am')
-rw-r--r--Build/source/texk/detex/Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/Build/source/texk/detex/Makefile.am b/Build/source/texk/detex/Makefile.am
new file mode 100644
index 00000000000..532485d4028
--- /dev/null
+++ b/Build/source/texk/detex/Makefile.am
@@ -0,0 +1,49 @@
+## $Id$
+## Makefile.am for the TeX Live subdirectory texk/detex/
+##
+## Copyright 2017 Karl Berry <tex-live@tug.org>
+## Copyright 2009-2015 Peter Breitenlohner <tex-live@tug.org>
+## You may freely use, modify and/or distribute this file.
+##
+## We want to re-distribute the whole original detex source tree.
+EXTRA_DIST = $(DETEX_TREE)
+## Patches applied to the original source tree
+EXTRA_DIST += TLpatches
+
+# Files not to be distributed
+include $(srcdir)/../../am/dist_hook.am
+NEVER_NAMES += $(NEVER_NAMES_SUB)
+
+AM_CPPFLAGS = -I$(top_srcdir)/$(DETEX_TREE) $(KPATHSEA_INCLUDES) -DNO_MALLOC_DECL -DKPATHSEA -Dlint
+AM_CFLAGS = $(WARNING_CFLAGS)
+
+## The Makefile.in from 2002 by Thomas Esser applied the sed script
+## states.sed to detex.l in order to "convert long labels to a shorter
+## form so lex(1) won't overflow". This should no longer be needed.
+## Moreover, Automake distributes the `detex.c' generated from `detex.l'.
+
+bin_PROGRAMS = detex
+
+detex_SOURCES = \
+ @DETEX_TREE@/detex.h \
+ @DETEX_TREE@/detex.l
+
+LDADD = $(KPATHSEA_LIBS)
+
+$(detex_OBJECTS): $(KPATHSEA_DEPEND)
+
+## Rebuild libkpathsea
+@KPATHSEA_RULE@
+
+man1_MANS = \
+ $(DETEX_TREE)/detex.man
+
+dist_check_SCRIPTS = detex.test
+
+TESTS = detex.test
+detex.log: detex$(EXEEXT)
+
+EXTRA_DIST += test.lout test.tex test.tout
+
+CLEANFILES = test.out texmf.cnf
+