summaryrefslogtreecommitdiff
path: root/Build/source/libs/pplib/configure.ac
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2021-02-25 19:22:25 +0000
committerKarl Berry <karl@freefriends.org>2021-02-25 19:22:25 +0000
commitad547a6b5986815fda458221149728d9d9ab1d87 (patch)
tree16296910eb3eca724371474ea9aea3994dc69614 /Build/source/libs/pplib/configure.ac
parent947b43de3dd21d58ccc2ffadefc4441ea1c2a813 (diff)
restore Build,TODO from r57911
git-svn-id: svn://tug.org/texlive/trunk@57915 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/pplib/configure.ac')
-rw-r--r--Build/source/libs/pplib/configure.ac64
1 files changed, 64 insertions, 0 deletions
diff --git a/Build/source/libs/pplib/configure.ac b/Build/source/libs/pplib/configure.ac
new file mode 100644
index 00000000000..634726b7ed4
--- /dev/null
+++ b/Build/source/libs/pplib/configure.ac
@@ -0,0 +1,64 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl Copyright (C) 2013, 2014 Peter Breitenlohner <tex-live@tug.org>
+dnl
+dnl This file is free software; the copyright holder
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+dnl
+m4_include([version.ac])[] dnl define pplib_version
+AC_INIT([pplib (TeX Live)], pplib_version, [tex-k@tug.org])
+AC_PREREQ([2.65])
+AC_CONFIG_SRCDIR([pplib-src/src/pplib.h])
+AC_CONFIG_AUX_DIR([../../build-aux])
+AC_CONFIG_MACRO_DIR([../../m4])
+
+KPSE_BASIC([pplib])
+
+AC_PROG_CC
+AC_PROG_CC_C99
+AC_PROG_RANLIB
+AC_PROG_LN_S
+
+AC_SUBST([PPLIBVERSION], [pplib_version])
+KPSE_LT_VERSION([pplib])
+
+LT_INIT([win32-dll])
+
+KPSE_DLL_NAME([pplib], [pplib])
+
+AC_CONFIG_HEADERS([config.h])[]dnl unused, to avoid zillions of -D's on command line
+
+AM_CONDITIONAL([build], [test "x$enable_build" != xno])
+
+
+#KPSE_PPLIB_DEFINES
+KPSE_LARGEFILE([PPLIB])
+
+KPSE_ZLIB_FLAGS
+
+AM_CONDITIONAL([build], [test "x$enable_build" != xno])
+
+if test "x$enable_build" != xno || test -f config.force; then
+
+KPSE_ADD_FLAGS([zlib])
+AC_CHECK_FUNC([zlibVersion], , [AC_ERROR([zlib not found])])
+KPSE_RESTORE_FLAGS
+
+echo timestamp >config.force
+fi
+
+
+
+if test "x$ac_cv_header_stdc" = xyes; then
+ PPLIB_DEFINES="$PPLIB_DEFINES -DHAVE_UNISTD_H"
+fi
+
+#PPLIB_DEFINES="$PPLIB_DEFINES -DEXTRA"
+#PPLIB_CFLAGS="-DEXTRA"
+
+AC_SUBST([PPLIB_TREE], [pplib-src])
+
+AC_CONFIG_FILES([Makefile include/Makefile])
+
+AC_OUTPUT