summaryrefslogtreecommitdiff
path: root/Build/source/libs/potrace/configure.ac
diff options
context:
space:
mode:
authorLuigi Scarso <luigi.scarso@gmail.com>2022-08-22 21:33:05 +0000
committerLuigi Scarso <luigi.scarso@gmail.com>2022-08-22 21:33:05 +0000
commitbf1717d383aa30df85c1981587f04b53ccbaf608 (patch)
tree7aef294a0dec56a1cea52e6e88b3c90b3cab757f /Build/source/libs/potrace/configure.ac
parent7754712818064ff1f642a248ab9817ef4e2d7a90 (diff)
Potrace under libs (again) for dvisvgm and mflua/mfluajit.
git-svn-id: svn://tug.org/texlive/trunk@64168 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/potrace/configure.ac')
-rw-r--r--Build/source/libs/potrace/configure.ac50
1 files changed, 50 insertions, 0 deletions
diff --git a/Build/source/libs/potrace/configure.ac b/Build/source/libs/potrace/configure.ac
new file mode 100644
index 00000000000..7c336bc990e
--- /dev/null
+++ b/Build/source/libs/potrace/configure.ac
@@ -0,0 +1,50 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl Copyright (C) 2022 Luigi Scarso <tex-live@tug.org>
+dnl
+dnl This file is free software; the copyright holder
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+dnl
+m4_include([version.ac])[] dnl define potrace_version
+AC_INIT([potrace (TeX Live)], potrace_version, [tex-k@tug.org])
+AC_PREREQ([2.65])
+AC_CONFIG_SRCDIR([potrace-src/src/potracelib.h])
+AC_CONFIG_AUX_DIR([../../build-aux])
+AC_CONFIG_MACRO_DIR([../../m4])
+
+KPSE_BASIC([potrace])
+
+dnl KPSE_LIB_VERSION([potrace])[]dnl
+
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_RANLIB
+AC_PROG_LN_S
+AC_C_INLINE
+
+
+AC_CONFIG_HEADERS([config.h])
+
+AM_CONDITIONAL([build], [test "x$enable_build" != xno])
+
+## Do we need to check STDC ?
+AC_HEADER_STDC
+dnl if test "x$ac_cv_header_stdc" != xyes; then
+dnl AC_MSG_ERROR([Sorry, can't do anything for you])
+dnl fi
+
+AC_SEARCH_LIBS([sqrt], [m])
+
+dnl Check for types
+
+AC_TYPE_UINT64_T
+
+
+
+AC_SUBST([POTRACE_TREE], [potrace-src])
+
+AC_CONFIG_FILES([Makefile include/Makefile])
+
+AC_OUTPUT