summaryrefslogtreecommitdiff
path: root/Build/source/libs/potrace/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2013-06-24 08:42:05 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2013-06-24 08:42:05 +0000
commit6c998f4d3d5f21632bc1d2c87073afa9e6b9fc70 (patch)
tree744e35567422c74346b5522ce78ff90b1820dc5a /Build/source/libs/potrace/configure.ac
parent99775fd0202a5394fc8bb9f929e992ce43dd8214 (diff)
potrace 1.11 - new, no longer part of dvisvgm
git-svn-id: svn://tug.org/texlive/trunk@30885 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/potrace/configure.ac')
-rw-r--r--Build/source/libs/potrace/configure.ac38
1 files changed, 38 insertions, 0 deletions
diff --git a/Build/source/libs/potrace/configure.ac b/Build/source/libs/potrace/configure.ac
new file mode 100644
index 00000000000..7c8d6894e26
--- /dev/null
+++ b/Build/source/libs/potrace/configure.ac
@@ -0,0 +1,38 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl Copyright (C) 2013 Peter Breitenlohner <tex-live@tug.org>
+dnl
+dnl This file is free software; the copyright holder
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+dnl
+m4_include([version.ac])[] dnl define potrace_version
+AC_INIT([potrace for TeX Live], potrace_version, [tex-k@tug.org])
+AC_PREREQ([2.65])
+AC_CONFIG_SRCDIR([potrace-]potrace_version[/src/trace.c])
+AC_CONFIG_AUX_DIR([../../build-aux])
+AC_CONFIG_MACRO_DIR([../../m4])
+
+KPSE_BASIC([potrace])
+
+AC_PROG_CC
+AC_PROG_RANLIB
+AC_PROG_LN_S
+AC_C_INLINE
+
+AC_CONFIG_HEADERS([config.h])
+
+AM_CONDITIONAL([build], [test "x$enable_build" != xno])
+
+AC_HEADER_STDC
+if test "x$ac_cv_header_stdc" != xyes; then
+ AC_MSG_ERROR([Sorry, can't do anything for you])
+fi
+
+AC_SEARCH_LIBS([sqrt], [m])
+
+AC_SUBST([POTRACE_TREE], [potrace-]potrace_version)
+
+AC_CONFIG_FILES([Makefile include/Makefile])
+
+AC_OUTPUT