summaryrefslogtreecommitdiff
path: root/Build/source/libs/libpng/libpng-src/configure.ac
diff options
context:
space:
mode:
authorAkira Kakuto <kakuto@fuk.kindai.ac.jp>2022-11-21 07:14:37 +0000
committerAkira Kakuto <kakuto@fuk.kindai.ac.jp>2022-11-21 07:14:37 +0000
commitd21d8428c8716c011e423661089d4f75a37ddf39 (patch)
treeefc38fe1ea63e9d31af2aff966785d60e4e531b1 /Build/source/libs/libpng/libpng-src/configure.ac
parent5dcad7d0ef1f73542bb60dac43e0eba6d1c0eaf0 (diff)
libpng 1.6.39
git-svn-id: svn://tug.org/texlive/trunk@65063 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/libpng/libpng-src/configure.ac')
-rw-r--r--Build/source/libs/libpng/libpng-src/configure.ac14
1 files changed, 8 insertions, 6 deletions
diff --git a/Build/source/libs/libpng/libpng-src/configure.ac b/Build/source/libs/libpng/libpng-src/configure.ac
index 7b6d5b929cf..986c7747021 100644
--- a/Build/source/libs/libpng/libpng-src/configure.ac
+++ b/Build/source/libs/libpng/libpng-src/configure.ac
@@ -25,7 +25,7 @@ AC_PREREQ([2.68])
dnl Version number stuff here:
-AC_INIT([libpng],[1.6.38],[png-mng-implement@lists.sourceforge.net])
+AC_INIT([libpng],[1.6.39],[png-mng-implement@lists.sourceforge.net])
AC_CONFIG_MACRO_DIR([scripts])
# libpng does not follow GNU file name conventions (hence 'foreign')
@@ -46,10 +46,10 @@ dnl automake, so the following is not necessary (and is not defined anyway):
dnl AM_PREREQ([1.11.2])
dnl stop configure from automagically running automake
-PNGLIB_VERSION=1.6.38
+PNGLIB_VERSION=1.6.39
PNGLIB_MAJOR=1
PNGLIB_MINOR=6
-PNGLIB_RELEASE=38
+PNGLIB_RELEASE=39
dnl End of version number stuff
@@ -138,7 +138,8 @@ AC_STRUCT_TM
AC_C_RESTRICT
# Checks for library functions.
-AC_CHECK_FUNCS([pow], , AC_CHECK_LIB(m, pow, , AC_MSG_ERROR(cannot find pow)))
+AC_CHECK_FUNCS([pow], ,
+ [AC_CHECK_LIB([m], [pow], , [AC_MSG_ERROR([cannot find pow])])])
# Some later POSIX 1003.1 functions are required for test programs, failure
# here is soft (the corresponding test program is not built).
@@ -150,8 +151,9 @@ AC_ARG_WITH(zlib-prefix,
[prefix that may have been used in installed zlib]),
[ZPREFIX=${withval}],
[ZPREFIX='z_'])
-AC_CHECK_LIB(z, zlibVersion, ,
- AC_CHECK_LIB(z, ${ZPREFIX}zlibVersion, , AC_MSG_ERROR(zlib not installed)))
+AC_CHECK_LIB([z], [zlibVersion], ,
+ [AC_CHECK_LIB([z], [${ZPREFIX}zlibVersion], ,
+ [AC_MSG_ERROR([zlib not installed])])])
# The following is for pngvalid, to ensure it catches FP errors even on
# platforms that don't enable FP exceptions, the function appears in the math