summaryrefslogtreecommitdiff
path: root/Build/source/libs/harfbuzz/harfbuzz-src/configure.ac
diff options
context:
space:
mode:
authorAkira Kakuto <kakuto@fuk.kindai.ac.jp>2020-07-25 10:48:52 +0000
committerAkira Kakuto <kakuto@fuk.kindai.ac.jp>2020-07-25 10:48:52 +0000
commit120fbb4ff2102335d09b937b3b63a9eed6ab66bb (patch)
tree536783132e9340733acf05aa2086936b22066771 /Build/source/libs/harfbuzz/harfbuzz-src/configure.ac
parent838bc80097f80371675cb700320a76c6a0ea6ab6 (diff)
harfbuzz-2.7.0
git-svn-id: svn://tug.org/texlive/trunk@55937 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/harfbuzz/harfbuzz-src/configure.ac')
-rw-r--r--Build/source/libs/harfbuzz/harfbuzz-src/configure.ac22
1 files changed, 5 insertions, 17 deletions
diff --git a/Build/source/libs/harfbuzz/harfbuzz-src/configure.ac b/Build/source/libs/harfbuzz/harfbuzz-src/configure.ac
index df51f6f7466..1f94273bf43 100644
--- a/Build/source/libs/harfbuzz/harfbuzz-src/configure.ac
+++ b/Build/source/libs/harfbuzz/harfbuzz-src/configure.ac
@@ -1,6 +1,6 @@
AC_PREREQ([2.64])
AC_INIT([HarfBuzz],
- [2.6.8],
+ [2.7.0],
[https://github.com/harfbuzz/harfbuzz/issues/new],
[harfbuzz],
[http://harfbuzz.org/])
@@ -46,16 +46,7 @@ AC_SUBST(HB_VERSION)
# Libtool version
m4_define([hb_version_int],
m4_eval(hb_version_major*10000 + hb_version_minor*100 + hb_version_micro))
-m4_if(m4_eval(hb_version_minor % 2), [1],
- dnl for unstable releases
- [m4_define([hb_libtool_revision], 0)],
- dnl for stable releases
- [m4_define([hb_libtool_revision], hb_version_micro)])
-m4_define([hb_libtool_age],
- m4_eval(hb_version_int - hb_libtool_revision))
-m4_define([hb_libtool_current],
- m4_eval(hb_libtool_age))
-HB_LIBTOOL_VERSION_INFO=hb_libtool_current:hb_libtool_revision:hb_libtool_age
+HB_LIBTOOL_VERSION_INFO=hb_version_int:0:hb_version_int
AC_SUBST(HB_LIBTOOL_VERSION_INFO)
AC_ARG_WITH([libstdc++],
@@ -77,7 +68,7 @@ GTK_DOC_CHECK([1.15],[--flavour no-tmpl])
])
# Functions and headers
-AC_CHECK_FUNCS(atexit mprotect sysconf getpagesize mmap isatty roundf)
+AC_CHECK_FUNCS(atexit mprotect sysconf getpagesize mmap isatty)
AC_CHECK_HEADERS(unistd.h sys/mman.h stdbool.h)
# Compiler flags
@@ -512,11 +503,8 @@ echo
AC_MSG_NOTICE([
-Autotools still is our main and recommended build system for
-building *nix package out of the library yet we encourage
-packagers to experiment with our brand new meson port and
-give us feedback as our effort to migrate and unify all
-the other build systems we have tools to meson.
+Autotools is no longer our supported build system for building the library
+for *nix distributions, please migrate to meson.
])