summaryrefslogtreecommitdiff
path: root/Build/source/libs/harfbuzz/configure.ac
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2017-11-01 00:09:02 +0000
committerKarl Berry <karl@freefriends.org>2017-11-01 00:09:02 +0000
commit1678d8502cb714a244fe67ac5acc99901ad471e3 (patch)
tree25993939325d5965a17f1003692c845c5cd390c8 /Build/source/libs/harfbuzz/configure.ac
parentdbd0461bf5d6723d35019ce3bd3a99a4ac1f418f (diff)
harfbuzz 1.6.3 configure: gcc -std=c++11 et al.
git-svn-id: svn://tug.org/texlive/trunk@45663 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/harfbuzz/configure.ac')
-rw-r--r--Build/source/libs/harfbuzz/configure.ac33
1 files changed, 29 insertions, 4 deletions
diff --git a/Build/source/libs/harfbuzz/configure.ac b/Build/source/libs/harfbuzz/configure.ac
index 75e3ae77176..a0f03b4bfb4 100644
--- a/Build/source/libs/harfbuzz/configure.ac
+++ b/Build/source/libs/harfbuzz/configure.ac
@@ -1,6 +1,7 @@
dnl Process this file with autoconf to produce a configure script.
dnl
-dnl Copyright (C) 2012-2015 Peter Breitenlohner <tex-live@tug.org>
+dnl Copyright 2016-2017 Karl Berry <tex-live@tug.org>
+dnl Copyright 2012-2015 Peter Breitenlohner <tex-live@tug.org>
dnl
dnl This file is free software; the copyright holder
dnl gives unlimited permission to copy and/or distribute it,
@@ -30,22 +31,46 @@ KPSE_GRAPHITE2_FLAGS
KPSE_ICU_FLAGS
# Functions and headers
-AC_CHECK_FUNCS([atexit mprotect sysconf getpagesize sched_yield mmap _setmode isatty])
-AC_CHECK_HEADERS([unistd.h sys/mman.h sched.h io.h])
+AC_CHECK_FUNCS(atexit mprotect sysconf getpagesize mmap isatty newlocale strtod_l)
+AC_CHECK_HEADERS(unistd.h sys/mman.h xlocale.h)
# Compiler flags
AC_CANONICAL_HOST
AC_CHECK_ALIGNOF([struct{char;}])
if test "x$GCC" = "xyes"; then
+
+ # Make symbols link locally
+ LDFLAGS="$LDFLAGS -Bsymbolic-functions"
+
+ # Choose C++ version
+ CXXFLAGS="$CXXFLAGS -std=c++11"
+
+ # Make sure we don't link to libstdc++
+ CXXFLAGS="$CXXFLAGS -fno-rtti -fno-exceptions"
+
+ # Assorted warnings
+ CXXFLAGS="$CXXFLAGS -Wcast-align"
+
+ case "$host" in
+ *-*-mingw*)
+ ;;
+ *)
+ # Hide inline methods
+ CXXFLAGS="$CXXFLAGS -fvisibility-inlines-hidden"
+ ;;
+ esac
+
case "$host" in
arm-*-*)
if test "x$ac_cv_alignof_struct_char__" != x1; then
# Request byte alignment
- AM_CXXFLAGS="-mstructure-size-boundary=8"
+ CXXFLAGS="$CXXFLAGS -mstructure-size-boundary=8"
fi
;;
esac
fi
+AM_CONDITIONAL(HAVE_GCC, test "x$GCC" = "xyes")
+
AC_SUBST([AM_CXXFLAGS])
AC_CONFIG_HEADERS([config.h])