summaryrefslogtreecommitdiff
path: root/Build/source/libs/graphite/Makefile.am
diff options
context:
space:
mode:
authorKhaled Hosny <khaledhosny@eglug.org>2013-01-03 09:49:07 +0000
committerKhaled Hosny <khaledhosny@eglug.org>2013-01-03 09:49:07 +0000
commitd3008cd626e7d131a9e487942a91ee085a157c83 (patch)
tree8b33ccb9666832e1cefd9863fad64b49f2835633 /Build/source/libs/graphite/Makefile.am
parentce108d3fea94e3b9cce73edd5dca42aec928dfc2 (diff)
Drop, now unused, SilGraphite engine
git-svn-id: svn://tug.org/texlive/trunk@28711 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/libs/graphite/Makefile.am')
-rw-r--r--Build/source/libs/graphite/Makefile.am63
1 files changed, 0 insertions, 63 deletions
diff --git a/Build/source/libs/graphite/Makefile.am b/Build/source/libs/graphite/Makefile.am
deleted file mode 100644
index 8f711de11b0..00000000000
--- a/Build/source/libs/graphite/Makefile.am
+++ /dev/null
@@ -1,63 +0,0 @@
-## Makefile.am for the TeX Live subdirectory libs/graphite/
-##
-## Copyright (C) 2009-2012 Peter Breitenlohner <tex-live@tug.org>
-## You may freely use, modify and/or distribute this file.
-##
-ACLOCAL_AMFLAGS = -I ../../m4
-
-# Rebuild
-.PHONY: rebuild
-rebuild: all
-
-## We want to re-distribute the whole original silgraphite/engine source tree.
-##
-## With current automake (1.10.2) 'make distcheck' fails when
-## DISTFILES contains a directory and files in that directory.
-## Thus nodist_* for all files in $(TECKIT_TREE).
-EXTRA_DIST = $(GRAPHITE_TREE)
-
-## Patches applied to the original source tree
-##
-EXTRA_DIST += $(GRAPHITE_TREE)-PATCHES
-
-# in case of an SVN repository
-dist-hook:
- rm -rf `find $(distdir) -name .svn`
-
-SUBDIRS = include/graphite
-
-AM_CPPFLAGS = -I$(top_srcdir)/$(GRAPHITE_TREE)/include/graphite -I$(top_srcdir)/$(GRAPHITE_TREE)/src/generic
-AM_CPPFLAGS += -I$(top_srcdir)/$(GRAPHITE_TREE)/src/font -I$(top_srcdir)/$(GRAPHITE_TREE)/src/segment
-AM_CPPFLAGS += -DNDEBUG
-AM_CFLAGS = $(WARNING_CFLAGS)
-AM_CXXFLAGS = $(WARNING_CXXFLAGS)
-
-noinst_LIBRARIES = libgraphite.a
-
-nodist_libgraphite_a_SOURCES = \
- $(GRAPHITE_TREE)/src/font/FileFont.cpp \
- $(GRAPHITE_TREE)/src/font/Font.cpp \
- $(GRAPHITE_TREE)/src/font/TtfUtil.cpp \
- $(GRAPHITE_TREE)/src/generic/Debug.cpp \
- $(GRAPHITE_TREE)/src/generic/Util.cpp \
- $(GRAPHITE_TREE)/src/painter/SegmentPainter.cpp \
- $(GRAPHITE_TREE)/src/segment/FileInput.cpp \
- $(GRAPHITE_TREE)/src/segment/FontCache.cpp \
- $(GRAPHITE_TREE)/src/segment/FontFace.cpp \
- $(GRAPHITE_TREE)/src/segment/GrCharStream.cpp \
- $(GRAPHITE_TREE)/src/segment/GrClassTable.cpp \
- $(GRAPHITE_TREE)/src/segment/GrEngine.cpp \
- $(GRAPHITE_TREE)/src/segment/GrFSM.cpp \
- $(GRAPHITE_TREE)/src/segment/GrFeature.cpp \
- $(GRAPHITE_TREE)/src/segment/GrGlyphTable.cpp \
- $(GRAPHITE_TREE)/src/segment/GrPass.cpp \
- $(GRAPHITE_TREE)/src/segment/GrPassActionCode.cpp \
- $(GRAPHITE_TREE)/src/segment/GrSlotState.cpp \
- $(GRAPHITE_TREE)/src/segment/GrSlotStream.cpp \
- $(GRAPHITE_TREE)/src/segment/GrTableManager.cpp \
- $(GRAPHITE_TREE)/src/segment/MemoryUsage.cpp \
- $(GRAPHITE_TREE)/src/segment/Platform.cpp \
- $(GRAPHITE_TREE)/src/segment/Segment.cpp \
- $(GRAPHITE_TREE)/src/segment/SegmentAux.cpp \
- $(GRAPHITE_TREE)/src/segment/TransductionLog.cpp
-