summaryrefslogtreecommitdiff
path: root/Build/source/configure.ac
diff options
context:
space:
mode:
authorPeter Breitenlohner <peb@mppmu.mpg.de>2013-07-07 14:29:53 +0000
committerPeter Breitenlohner <peb@mppmu.mpg.de>2013-07-07 14:29:53 +0000
commit0df6dd4d8aea6edc733de81fb7eec115ea59a36e (patch)
treee2f7056cb53c58c8ef5779450ac468091b2bd86d /Build/source/configure.ac
parent3675a91dd83af3eaa1c1a12e91af1e6c86f710f8 (diff)
build system: additional Makefile fragments
better handling of dependencies for highly parallel make git-svn-id: svn://tug.org/texlive/trunk@31127 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/configure.ac')
-rw-r--r--Build/source/configure.ac14
1 files changed, 7 insertions, 7 deletions
diff --git a/Build/source/configure.ac b/Build/source/configure.ac
index d5a1730195c..242e4c7cbf7 100644
--- a/Build/source/configure.ac
+++ b/Build/source/configure.ac
@@ -112,25 +112,25 @@ if test "x$enable_web2c" = xyes && test "x$with_system_kpathsea" = xyes; then
fi
AC_MSG_CHECKING([for TeX specific libraries to build])
-TEXLIBS=
-DIST_TEXLIBS=
+MAKE_SUBDIRS=
+CONF_SUBDIRS=
KPSE_FOR_PKGS([texlibs], [
if test -x $srcdir/texk/Kpse_Pkg/configure; then
if test "x$with_system_[]Kpse_pkg" != xyes && \
test "x$need_[]Kpse_pkg" = xyes; then
- TEXLIBS="texk/Kpse_Pkg $TEXLIBS"
+ MAKE_SUBDIRS="texk/Kpse_Pkg $MAKE_SUBDIRS"
fi
dnl Cause 'make dist' to recurse into all texlibs dirs
- DIST_TEXLIBS="texk/Kpse_Pkg $DIST_TEXLIBS"
+ CONF_SUBDIRS="texk/Kpse_Pkg $CONF_SUBDIRS"
dnl Cause 'configure -hr' and 'autoreconf' to recurse into all texlibs dirs
if false; then
AC_CONFIG_SUBDIRS([texk/]Kpse_Pkg)
fi
fi
])
-AC_SUBST([TEXLIBS])
-AC_SUBST([DIST_TEXLIBS])
-AC_MSG_RESULT([$TEXLIBS])
+AC_SUBST([MAKE_SUBDIRS])
+AC_SUBST([CONF_SUBDIRS])
+AC_MSG_RESULT([$MAKE_SUBDIRS])
dnl We check that all required system libraries are usable, and may
dnl reduce frustration if anything is wrong by doing this first.