summaryrefslogtreecommitdiff
path: root/Build/source/Makefile.am
diff options
context:
space:
mode:
authorKarl Berry <karl@freefriends.org>2016-11-15 23:43:43 +0000
committerKarl Berry <karl@freefriends.org>2016-11-15 23:43:43 +0000
commit3173fd07df8bc7d3208dfa114dc14003cc48e525 (patch)
treea8ddf85c759a7e347e219a55d64ea4342dbaed5e /Build/source/Makefile.am
parent6b55b974e96b4b9aa8c15701d085d106c8d689f4 (diff)
(install-exec-hook): warn that support files are required for a usable installation
git-svn-id: svn://tug.org/texlive/trunk@42520 c570f23f-e606-0410-a88d-b1316a301751
Diffstat (limited to 'Build/source/Makefile.am')
-rw-r--r--Build/source/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Build/source/Makefile.am b/Build/source/Makefile.am
index d30d075f43a..3807c07d0a1 100644
--- a/Build/source/Makefile.am
+++ b/Build/source/Makefile.am
@@ -1,6 +1,8 @@
+## $Id$
## Makefile.am for the TeX Live top-level
##
-## Copyright (C) 2009-2015 Peter Breitenlohner <tex-live@tug.org>
+## Copyright 2016 Karl Berry <tex-live@tug.org>
+## Copyright 2009-2015 Peter Breitenlohner <tex-live@tug.org>
## You may freely use, modify and/or distribute this file.
##
## Ensure aclocal.m4 is up to date
@@ -59,6 +61,12 @@ world: all
##
@echo "top-level make $@ done."
+install-exec-hook:
+ @echo "WARNING: make install does not result in a usable TeX!"
+ @echo " ! The binaries require the myriad support files."
+ @echo " ! See http://tug.org/texlive/distro.html"
+ @echo " ! and http://tug.org/texlive/build.html#deploy, for example."
+
# Allow for skipping make check if needed.
if cross
check_target = skip