summaryrefslogtreecommitdiff
path: root/support/texlab/crates/texlab/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'support/texlab/crates/texlab/Cargo.toml')
-rw-r--r--support/texlab/crates/texlab/Cargo.toml25
1 files changed, 12 insertions, 13 deletions
diff --git a/support/texlab/crates/texlab/Cargo.toml b/support/texlab/crates/texlab/Cargo.toml
index 9b120d7884..099e0cc8c7 100644
--- a/support/texlab/crates/texlab/Cargo.toml
+++ b/support/texlab/crates/texlab/Cargo.toml
@@ -1,7 +1,7 @@
[package]
name = "texlab"
description = "LaTeX Language Server"
-version = "5.11.0"
+version = "5.12.0"
license.workspace = true
readme = "README.md"
authors.workspace = true
@@ -12,7 +12,7 @@ repository = "https://github.com/latex-lsp/texlab"
documentation = "https://github.com/latex-lsp/texlab"
keywords = ["lsp", "server", "latex", "bibtex"]
categories = ["development-tools"]
-exclude = ["tests/it/**", "*.snap"]
+exclude = ["*.snap"]
[[bin]]
name = "texlab"
@@ -24,8 +24,9 @@ doctest = false
[dependencies]
anyhow = "1.0.75"
base-db = { path = "../base-db" }
+bibfmt = { path = "../bibfmt" }
citeproc = { path = "../citeproc" }
-clap = { version = "4.4.4", features = ["derive"] }
+clap = { version = "4.4.10", features = ["derive"] }
commands = { path = "../commands" }
completion = { path = "../completion" }
completion-data = { path = "../completion-data" }
@@ -37,10 +38,11 @@ encoding_rs = "0.8.33"
encoding_rs_io = "0.1.7"
fern = "0.6.2"
folding = { path = "../folding" }
-fuzzy-matcher = { version = "0.3.7", features = ["compact"] }
+highlights = { path = "../highlights" }
hover = { path = "../hover" }
inlay-hints = { path = "../inlay-hints" }
-itertools = "0.11.0"
+line-index = { path = "../line-index" }
+links = { path = "../links" }
log = "0.4.19"
lsp-server = "0.7.4"
lsp-types = "0.94.1"
@@ -49,25 +51,22 @@ notify-debouncer-full = "0.3.1"
once_cell = "1.18.0"
parking_lot = "0.12.1"
parser = { path = "../parser" }
-rayon = "1.8.0"
references = { path = "../references" }
-regex = "1.9.5"
+regex = "1.10.2"
rename = { path = "../rename" }
-rowan = "0.15.11"
+rowan = "0.15.13"
rustc-hash = "1.1.0"
-serde = "1.0.188"
-serde_json = "1.0.107"
+serde = "1.0.193"
+serde_json = "1.0.108"
serde_regex = "1.1.0"
-serde_repr = "0.1.16"
+serde_repr = "0.1.17"
symbols = { path = "../symbols" }
syntax = { path = "../syntax" }
tempfile = "3.8.0"
threadpool = "1.8.1"
[dev-dependencies]
-assert_unordered = "0.3.5"
criterion = { version = "0.5.1" }
-insta = { version = "1.32.0", features = ["glob", "redactions", "json"] }
[[bench]]
name = "bench_main"