summaryrefslogtreecommitdiff
path: root/support/texlab/crates/texlab/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'support/texlab/crates/texlab/Cargo.toml')
-rw-r--r--support/texlab/crates/texlab/Cargo.toml12
1 files changed, 6 insertions, 6 deletions
diff --git a/support/texlab/crates/texlab/Cargo.toml b/support/texlab/crates/texlab/Cargo.toml
index 45f6e6b418..0162fe499a 100644
--- a/support/texlab/crates/texlab/Cargo.toml
+++ b/support/texlab/crates/texlab/Cargo.toml
@@ -1,7 +1,7 @@
[package]
name = "texlab"
description = "LaTeX Language Server"
-version = "5.12.1"
+version = "5.12.2"
license.workspace = true
readme = "README.md"
authors.workspace = true
@@ -30,7 +30,7 @@ clap = { version = "4.4.10", features = ["derive"] }
commands = { path = "../commands" }
completion = { path = "../completion" }
completion-data = { path = "../completion-data" }
-crossbeam-channel = "0.5.8"
+crossbeam-channel = "0.5.11"
definition = { path = "../definition" }
diagnostics = { path = "../diagnostics" }
distro = { path = "../distro" }
@@ -44,19 +44,19 @@ inlay-hints = { path = "../inlay-hints" }
line-index = { path = "../line-index" }
links = { path = "../links" }
log = "0.4.19"
-lsp-server = "0.7.4"
+lsp-server = "0.7.6"
lsp-types = "0.94.1"
notify = "6.1.1"
notify-debouncer-full = "0.3.1"
-once_cell = "1.18.0"
+once_cell = "1.19.0"
parking_lot = "0.12.1"
parser = { path = "../parser" }
references = { path = "../references" }
regex = "1.10.2"
rename = { path = "../rename" }
-rowan = "0.15.13"
+rowan = "0.15.15"
rustc-hash = "1.1.0"
-serde = "1.0.193"
+serde = "1.0.195"
serde_json = "1.0.108"
serde_regex = "1.1.0"
serde_repr = "0.1.17"