summaryrefslogtreecommitdiff
path: root/support/texlab/crates/texlab/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'support/texlab/crates/texlab/Cargo.toml')
-rw-r--r--support/texlab/crates/texlab/Cargo.toml13
1 files changed, 7 insertions, 6 deletions
diff --git a/support/texlab/crates/texlab/Cargo.toml b/support/texlab/crates/texlab/Cargo.toml
index 8fe5d4fbbe..4c142a2229 100644
--- a/support/texlab/crates/texlab/Cargo.toml
+++ b/support/texlab/crates/texlab/Cargo.toml
@@ -1,7 +1,7 @@
[package]
name = "texlab"
description = "LaTeX Language Server"
-version = "5.14.1"
+version = "5.16.0"
license.workspace = true
readme = "README.md"
authors.workspace = true
@@ -22,11 +22,11 @@ test = false
doctest = false
[dependencies]
-anyhow = "1.0.75"
+anyhow = "1.0.82"
base-db = { path = "../base-db" }
bibfmt = { path = "../bibfmt" }
citeproc = { path = "../citeproc" }
-clap = { version = "4.5.3", features = ["derive"] }
+clap = { version = "4.5.4", features = ["derive"] }
commands = { path = "../commands" }
completion = { path = "../completion" }
completion-data = { path = "../completion-data" }
@@ -39,22 +39,23 @@ folding = { path = "../folding" }
highlights = { path = "../highlights" }
hover = { path = "../hover" }
inlay-hints = { path = "../inlay-hints" }
+ipc = { path = "../ipc" }
line-index = { path = "../line-index" }
links = { path = "../links" }
log = "0.4.21"
lsp-server = "0.7.6"
-lsp-types = "0.95.0"
+lsp-types = "0.95.1"
notify = "6.1.1"
notify-debouncer-full = "0.3.1"
parking_lot = "0.12.1"
parser = { path = "../parser" }
references = { path = "../references" }
-regex = "1.10.2"
+regex = "1.10.4"
rename = { path = "../rename" }
rowan = "0.15.15"
rustc-hash = "1.1.0"
serde = "1.0.195"
-serde_json = "1.0.114"
+serde_json = "1.0.115"
serde_regex = "1.1.0"
serde_repr = "0.1.18"
symbols = { path = "../symbols" }