summaryrefslogtreecommitdiff
path: root/support/texlab/crates/texlab/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'support/texlab/crates/texlab/Cargo.toml')
-rw-r--r--support/texlab/crates/texlab/Cargo.toml20
1 files changed, 10 insertions, 10 deletions
diff --git a/support/texlab/crates/texlab/Cargo.toml b/support/texlab/crates/texlab/Cargo.toml
index 821ecb9813..1f9ca98abe 100644
--- a/support/texlab/crates/texlab/Cargo.toml
+++ b/support/texlab/crates/texlab/Cargo.toml
@@ -1,7 +1,7 @@
[package]
name = "texlab"
description = "LaTeX Language Server"
-version = "5.6.0"
+version = "5.7.0"
license.workspace = true
readme = "README.md"
authors.workspace = true
@@ -31,31 +31,31 @@ test = false
doctest = false
[dependencies]
-anyhow = "1.0.70"
+anyhow = "1.0.71"
base-db = { path = "../base-db" }
citeproc = { path = "../citeproc" }
-clap = { version = "4.2.2", features = ["derive"] }
+clap = { version = "4.3.0", features = ["derive"] }
commands = { path = "../commands" }
crossbeam-channel = "0.5.8"
-dirs = "5.0.0"
+dirs = "5.0.1"
distro = { path = "../distro" }
encoding_rs = "0.8.32"
encoding_rs_io = "0.1.7"
fern = "0.6.2"
-flate2 = "1.0.25"
+flate2 = "1.0.26"
fuzzy-matcher = { version = "0.3.7", features = ["compact"] }
itertools = "0.10.5"
log = "0.4.17"
lsp-server = "0.7.0"
lsp-types = "0.94.0"
-notify = "5.1.0"
+notify = "6.0.0"
once_cell = "1.17.1"
parking_lot = "0.12.1"
parser = { path = "../parser" }
-regex = "1.7.3"
+regex = "1.8.1"
rowan = "0.15.11"
rustc-hash = "1.1.0"
-serde = "1.0.160"
+serde = "1.0.163"
serde_json = "1.0.96"
serde_regex = "1.1.0"
serde_repr = "0.1.12"
@@ -68,8 +68,8 @@ symbols = { path = "../symbols" }
[dev-dependencies]
assert_unordered = "0.3.5"
-criterion = { version = "0.4.0" }
-insta = { version = "1.28.0", features = ["glob", "redactions", "json"] }
+criterion = { version = "0.5.1" }
+insta = { version = "1.29.0", features = ["glob", "redactions", "json"] }
[[bench]]
name = "bench_main"