summaryrefslogtreecommitdiff
path: root/support/texlab/crates/diagnostics/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'support/texlab/crates/diagnostics/Cargo.toml')
-rw-r--r--support/texlab/crates/diagnostics/Cargo.toml10
1 files changed, 10 insertions, 0 deletions
diff --git a/support/texlab/crates/diagnostics/Cargo.toml b/support/texlab/crates/diagnostics/Cargo.toml
index 7de9c6042d..1fb4b2171d 100644
--- a/support/texlab/crates/diagnostics/Cargo.toml
+++ b/support/texlab/crates/diagnostics/Cargo.toml
@@ -7,15 +7,25 @@ edition.workspace = true
rust-version.workspace = true
[dependencies]
+anyhow = "1.0.75"
base-db = { path = "../base-db" }
+dirs = "5.0.1"
+encoding_rs = "0.8.33"
+encoding_rs_io = "0.1.7"
itertools = "0.12.0"
line-index = { path = "../line-index" }
+log = "0.4.20"
+multimap = "0.9.1"
+once_cell = "1.19.0"
+parking_lot = "0.12.1"
+regex = "1.10.2"
rowan = "0.15.15"
rustc-hash = "1.1.0"
syntax = { path = "../syntax" }
url = "2.5.0"
[dev-dependencies]
+expect-test = "1.4.1"
test-utils = { path = "../test-utils" }
[lib]