summaryrefslogtreecommitdiff
path: root/support/texlab/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'support/texlab/Cargo.toml')
-rw-r--r--support/texlab/Cargo.toml140
1 files changed, 92 insertions, 48 deletions
diff --git a/support/texlab/Cargo.toml b/support/texlab/Cargo.toml
index 9c516ea864..56e90a2aa0 100644
--- a/support/texlab/Cargo.toml
+++ b/support/texlab/Cargo.toml
@@ -1,67 +1,111 @@
[package]
name = "texlab"
description = "LaTeX Language Server"
-version = "1.8.0"
-license = "GPLv3"
+version = "2.2.0"
+license = "GPL-3.0"
readme = "README.md"
authors = [
- "Eric Förster <efoerster@users.noreply.github.com>",
- "Patrick Förster <pfoerster@users.noreply.github.com>"]
+ "Eric Förster <eric.foerster@outlook.com>",
+ "Patrick Förster <patrick.foerster@outlook.de>",
+]
edition = "2018"
+homepage = "https://texlab.netlify.app"
[workspace]
-members = [
- "crates/bibutils",
- "crates/bibutils_sys",
- "crates/futures_boxed",
- "crates/jsonrpc",
- "crates/jsonrpc_derive",
- "crates/tex"]
+members = ["crates/*"]
+
+[lib]
+doctest = false
+
+[features]
+default = [
+ "citation",
+ "server",
+ "test",
+]
+citation = [
+ "bibutils-sys",
+ "citeproc",
+ "citeproc-db",
+ "citeproc-io",
+ "csl",
+ "fnv",
+ "html2md",
+ "lalrpop/lexer",
+ "lalrpop-util",
+]
+server = [
+ "bytes",
+ "jsonrpc",
+ "jsonrpc-derive",
+ "nom",
+ "tokio-util/codec",
+]
+test = [
+ "server",
+ "aovec",
+]
+
+[[bin]]
+name = "texlab"
+required-features = ["server"]
+
+[[test]]
+name = "integration"
+required-features = ["test"]
[dependencies]
-base64 = "0.11.0"
-bibutils = { path = "crates/bibutils" }
-bytes = "0.4.12"
-citeproc = { git = "https://github.com/cormacrelf/citeproc-rs", rev = "796ea0382392ae1befdc39f21162ed83b640ac29" }
-citeproc-db = { git = "https://github.com/cormacrelf/citeproc-rs", rev = "796ea0382392ae1befdc39f21162ed83b640ac29" }
-citeproc-io = { git = "https://github.com/cormacrelf/citeproc-rs", rev = "796ea0382392ae1befdc39f21162ed83b640ac29" }
-clap = "2.33"
-csl = { git = "https://github.com/cormacrelf/citeproc-rs", rev = "796ea0382392ae1befdc39f21162ed83b640ac29" }
-fnv = "1.0.3"
-futures-boxed = { path = "crates/futures_boxed" }
-futures-preview = "0.3.0-alpha.18"
-html2md = "0.2.9"
-image = "0.22.3"
-itertools = "0.8.2"
-jsonrpc = { path = "crates/jsonrpc" }
-jsonrpc-derive = { path = "crates/jsonrpc_derive" }
-lalrpop-util = "0.17.2"
-log = "0.4.6"
-lsp-types = { version = "0.61.0", features = ["proposed"] }
-nom = "5.0.1"
-once_cell = "1.2.0"
-path-clean = "0.1.0"
-petgraph = "0.4.13"
-regex = "1.3.1"
-serde = { version = "1.0.103", features = ["derive", "rc"] }
-serde_json = "1.0.42"
+async-trait = "0.1"
+aovec = { version = "1.1", optional = true }
+base64 = "0.12"
+bibutils-sys = { version = "0.1", optional = true }
+byteorder = "1.3"
+bytes = { version = "0.5", optional = true }
+chashmap = "2.2"
+cfg-if = "0.1"
+citeproc = { git = "https://github.com/cormacrelf/citeproc-rs", rev = "68c7a7c16088b5d7751641ab37299ad064cdb221", optional = true }
+citeproc-db = { git = "https://github.com/cormacrelf/citeproc-rs", rev = "68c7a7c16088b5d7751641ab37299ad064cdb221", optional = true }
+citeproc-io = { git = "https://github.com/cormacrelf/citeproc-rs", rev = "68c7a7c16088b5d7751641ab37299ad064cdb221", optional = true }
+csl = { git = "https://github.com/cormacrelf/citeproc-rs", rev = "68c7a7c16088b5d7751641ab37299ad064cdb221", optional = true }
+fern = "0.6"
+fnv = { version = "1.0", optional = true }
+futures = "0.3"
+fuzzy-matcher = "0.3"
+html2md = { version = "0.2", optional = true }
+image = "0.23"
+itertools = "0.9"
+jsonrpc = { path = "crates/jsonrpc", optional = true }
+jsonrpc-derive = { path = "crates/jsonrpc_derive", optional = true }
+lalrpop-util = { version = "0.18", optional = true }
+log = "0.4"
+lsp-types = { version = "0.74.1" }
+nom = { version = "5.1", optional = true }
+once_cell = "1.4"
+petgraph = { version = "0.5", features = ["serde-1"] }
+rayon = "1.3"
+regex = "1.3"
+serde = { version = "1.0", features = ["derive", "rc"] }
+serde_json = "1.0"
serde_repr = "0.1"
-stderrlog = "0.4.1"
-tempfile = "3"
-tex = { path = "crates/tex" }
-tokio = "0.2.0-alpha.6"
-tokio-net = { version = "0.2.0-alpha.6", features = ["process"]}
+structopt = "0.3"
+tempfile = "3.1"
+thiserror = "1.0"
+titlecase = "1.1"
+tokio = { version = "0.2", features = ["fs", "io-std", "macros", "process", "rt-core", "time"] }
+tokio-util = { version = "0.3", optional = true }
+url = "2.1"
uuid = { version = "0.8", features = ["v4"] }
-url = "2.0.0"
-url_serde = "0.2.0"
-walkdir = "2"
[dev-dependencies]
-copy_dir = "0.1.2"
-indoc = "0.3.4"
+criterion = "0.3"
+indoc = "0.3"
[build-dependencies]
-lalrpop = "0.17.2"
+lalrpop = { version = "0.18", optional = true }
[profile.release]
lto = true
+
+[[bench]]
+name = "bench_main"
+harness = false