summaryrefslogtreecommitdiff
path: root/support/pkgcheck/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'support/pkgcheck/Cargo.toml')
-rw-r--r--support/pkgcheck/Cargo.toml9
1 files changed, 7 insertions, 2 deletions
diff --git a/support/pkgcheck/Cargo.toml b/support/pkgcheck/Cargo.toml
index 0943bc76d7..39fe8901b5 100644
--- a/support/pkgcheck/Cargo.toml
+++ b/support/pkgcheck/Cargo.toml
@@ -1,11 +1,16 @@
[package]
name = "pkgcheck"
-version = "2.0.1"
+version = "2.1.0"
authors = ["Manfred Lotz <manfred@ctan.org>"]
description = "Command-line tool to check packages uploaded to CTAN."
license = "MIT/Apache-2.0"
edition = "2018"
+# with this option binaries are smaller
+# https://doc.rust-lang.org/edition-guide/rust-2018/error-handling-and-panics/aborting-on-panic.html
+[profile.release]
+panic = "abort"
+
[dependencies]
structopt = "0.3"
walkdir = "2.3"
@@ -23,7 +28,7 @@ reqwest = { version = "0.10", features = ["blocking", "gzip"] }
lazy_static = "1"
tempdir = "0.3"
-assert_cmd = "0.12"
+assert_cmd = "1"
predicates = "1"
openssl-probe = "0.1.2"
pest = "2.1"