summaryrefslogtreecommitdiff
path: root/support/pkgcheck/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'support/pkgcheck/Cargo.toml')
-rw-r--r--support/pkgcheck/Cargo.toml16
1 files changed, 8 insertions, 8 deletions
diff --git a/support/pkgcheck/Cargo.toml b/support/pkgcheck/Cargo.toml
index f7120709d4..c765d91590 100644
--- a/support/pkgcheck/Cargo.toml
+++ b/support/pkgcheck/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "pkgcheck"
-version = "3.0.0"
+version = "3.1.0"
authors = ["Manfred Lotz <manfred@ctan.org>"]
description = "Command-line tool to check packages uploaded to CTAN."
license = "MIT/Apache-2.0"
@@ -18,28 +18,28 @@ lto = true
[dependencies]
blake3 = "1.3"
-clap = { version = "3.1.6", features = ["derive"] }
-clap_complete = "3.1.1"
+clap = { version = "4", features = ["derive"] }
+clap_complete = "4"
colored = "2"
config = "0.13"
escargot = "0.5"
fern = "0.6"
glob = "0.3"
home = "0.5.3"
-once_cell = "1.10.0"
+once_cell = "1.13"
#lazy_static = "1"
-linkify = "0.8"
+linkify = "0.9"
log = "0.4"
num_cpus = "1"
openssl-probe = "0.1.4"
-pest = "2.1"
-pest_derive = "2.1"
+pest = "2.3"
+pest_derive = "2.3"
regex = "1"
reqwest = { version = "0.11", features = ["blocking", "gzip"] }
rustc-hash = "1.1"
scoped_threadpool = "0.1"
serde = { version = "1.0", features = ["derive"] }
-serde_yaml = "0.8"
+serde_yaml = "0.9"
tempfile = "3.1"
threadpool = "1.8"
tokio = { version = "1", features = ["full"] }