summaryrefslogtreecommitdiff
path: root/language/thai/thailatex/emacs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'language/thai/thailatex/emacs/Makefile.am')
-rw-r--r--language/thai/thailatex/emacs/Makefile.am37
1 files changed, 0 insertions, 37 deletions
diff --git a/language/thai/thailatex/emacs/Makefile.am b/language/thai/thailatex/emacs/Makefile.am
deleted file mode 100644
index c11e8cbe83..0000000000
--- a/language/thai/thailatex/emacs/Makefile.am
+++ /dev/null
@@ -1,37 +0,0 @@
-EXTRA_DIST = thai-latex-setup.el
-
-emacslispdir = $(emacsdir)/site-lisp
-emacslisp_DATA = thai-latex-setup.el
-
-EMACS_SITE_START=$(DESTDIR)$(emacslispdir)/site-start.el
-
-if ENABLE_HOOKS
-
-install-data-hook:
- @if test -z "$(DESTDIR)" ; then \
- if [ -f $(EMACS_SITE_START) ] ; then \
- $(SED) -e '/thai-latex-setup/d' $(EMACS_SITE_START) \
- > /tmp/tmp.$$$$ ; \
- mv /tmp/tmp.$$$$ $(EMACS_SITE_START) ; \
- fi ; \
- echo '(load-library "thai-latex-setup")' >> $(EMACS_SITE_START) ; \
- else \
- echo "***" ; \
- echo "*** Warning: Emacs site-start.el not patched" ; \
- echo "***" ; \
- echo "*** update the file on the target system" ; \
- echo "*** using 'sync-thailatex install'" ; \
- echo "***" ; \
- fi
-
-
-uninstall-hook:
- if [ -f $(EMACS_SITE_START) ] ; then \
- $(SED) -e '/thai-latex-setup/d' $(EMACS_SITE_START) \
- > /tmp/tmp.$$$$ ; \
- mv /tmp/tmp.$$$$ $(EMACS_SITE_START) ; \
- [ -s $(EMACS_SITE_START) ] || rm -f $(EMACS_SITE_START) ; \
- fi
-
-endif # ENABLE_HOOKS
-