summaryrefslogtreecommitdiff
path: root/indexing/upmendex/source/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'indexing/upmendex/source/configure.ac')
-rw-r--r--indexing/upmendex/source/configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/indexing/upmendex/source/configure.ac b/indexing/upmendex/source/configure.ac
index b3043309fa..7af5a44b8c 100644
--- a/indexing/upmendex/source/configure.ac
+++ b/indexing/upmendex/source/configure.ac
@@ -1,22 +1,19 @@
dnl $Id$
dnl Process this file with autoconf to produce a configure script.
dnl
-dnl Copyright 2015-2020 Karl Berry <tex-live@tug.org>
+dnl Copyright 2015-2021 Karl Berry <tex-live@tug.org>
dnl Copyright 2010-2015 Peter Breitenlohner <tex-live@tug.org>
dnl
dnl This file is free software; the copyright holder
dnl gives unlimited permission to copy and/or distribute it,
dnl with or without modifications, as long as this notice is preserved.
dnl
-AC_INIT([upmendex (TeX Live)], [0.55])
+AC_INIT([upmendex (TeX Live)], [0.58])
AC_PREREQ([2.63])
AC_CONFIG_SRCDIR([main.c])
AC_CONFIG_AUX_DIR([../../build-aux])
AC_CONFIG_MACRO_DIR([../../m4])
-AC_PROG_CXX
-KPSE_CXX_HACK
-
dnl Common code for all programs using libkpathsea.
KPSE_COMMON([upmendex], [no-define])
@@ -37,12 +34,15 @@ AS_CASE([$kpse_cv_have___VA_ARGS__],
[yes], [AC_DEFINE([HAVE___VA_ARGS__], 1,
[Define to 1 if you have C99 variadic macros.])])
+AC_PROG_CXX
+KPSE_CXX_HACK
+
dnl As of ICU 65.1, ICU requires -lpthread on x86_64-linux and, most
dnl likely, on other platforms. Otherwise there is a crash in
dnl std::call_once, as shown in ChangeLog. OpenBSD already has to link
-dnl with -lpthread on all platforms (see m4/kpse-icu-flags.m4), but so
-dnl far it seems only upmendex requires it elsewhere. The double
-dnl inclusion of -lpthread on obsd should be harmless.
+dnl with -lpthread on all platforms (see m4/kpse-icu-flags.m4), but the
+dnl double inclusion of -lpthread on obsd should be harmless. bibtexu
+dnl also needs pthread to avoid failures.
dnl
dnl The autoconf-archive ax_pthread macro (used in asymptote) goes to
dnl much greater lengths to find the best thread library and support all