summaryrefslogtreecommitdiff
path: root/graphics/asymptote/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/asymptote/configure.ac')
-rw-r--r--graphics/asymptote/configure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/graphics/asymptote/configure.ac b/graphics/asymptote/configure.ac
index 92dd1ded2b..5b7e118645 100644
--- a/graphics/asymptote/configure.ac
+++ b/graphics/asymptote/configure.ac
@@ -3,7 +3,7 @@
# this file.
AC_PREREQ(2)
-AC_INIT([Asymptote],[2.53],[http://sourceforge.net/projects/asymptote])
+AC_INIT([Asymptote],[2.54],[http://sourceforge.net/projects/asymptote])
VERSION=$PACKAGE_VERSION
AC_SUBST(VERSION)
m4_include([ax_pthread.m4])
@@ -362,10 +362,11 @@ AC_ARG_ENABLE(offscreen,
AC_ARG_ENABLE(OpenImageIO,
[AS_HELP_STRING(--enable-openimageio[[[=no]]],enable experimental OpenImageIO Library)])
-if test "x$enable_gl" != "xno"; then
AC_CHECK_HEADER(glm/glm.hpp,
[AC_DEFINE(HAVE_LIBGLM,1,
- DEFINE([the <glm/glm.hpp> header]))],AC_MSG_NOTICE([*** Could not find glm header files: will compile without OpenGL support ***]))
+ DEFINE([the <glm/glm.hpp> header]))],AC_MSG_NOTICE([*** Could not find glm header files: will compile without WebGL or OpenGL support ***]))
+
+if test "x$enable_gl" != "xno"; then
AC_CHECK_HEADERS([ncurses/curses.h ncurses.h curses.h],[break])
if test "x$enable_openimageio" = "xyes"; then
AC_CHECK_HEADER([OpenEXR/ImathVec.h],
@@ -400,7 +401,7 @@ case "$OSTYPE" in
*)
AC_CHECK_LIB([gccpp],[GC_throw_bad_alloc])
AC_CHECK_LIB([glut], [glutMainLoop],,
- AC_MSG_NOTICE([*** Could not find libglut: will compile without GLUT support ***]))
+ AC_MSG_NOTICE([*** Could not find libglut: will compile without OpenGL support ***]))
AC_CHECK_LIB([GL], [glDepthMask],
[AC_DEFINE(HAVE_LIBGL,1,
DEFINE_LIB([GL]))
@@ -429,7 +430,7 @@ AC_DEFUN([ac_FUNC_STRPTIME], [
# Checks for library functions.
AC_FUNC_FORK
-AC_CHECK_FUNCS([dup2 floor memset pow sqrt strchr tgamma memrchr])
+AC_CHECK_FUNCS([dup2 floor memset strchr tgamma lgamma memrchr])
AC_FUNC_STRFTIME
ac_FUNC_STRPTIME
AC_FUNC_ERROR_AT_LINE