summaryrefslogtreecommitdiff
path: root/graphics/asymptote/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/asymptote/configure.ac')
-rw-r--r--graphics/asymptote/configure.ac17
1 files changed, 12 insertions, 5 deletions
diff --git a/graphics/asymptote/configure.ac b/graphics/asymptote/configure.ac
index 6b8ef2f27a..cdd5e26b48 100644
--- a/graphics/asymptote/configure.ac
+++ b/graphics/asymptote/configure.ac
@@ -3,7 +3,7 @@
# this file.
AC_PREREQ(2)
-AC_INIT([Asymptote],[2.83],[https://github.com/vectorgraphics/asymptote/issues])
+AC_INIT([Asymptote],[2.84],[https://github.com/vectorgraphics/asymptote/issues])
VERSION=$PACKAGE_VERSION
AC_SUBST(VERSION)
m4_include([ax_pthread.m4])
@@ -114,7 +114,14 @@ AC_PROG_CXX
AC_PROG_INSTALL
AC_PROG_CC
AC_PROG_MAKE_SET
-AC_PROG_YACC
+
+AC_ARG_VAR([BISON], [bison command])
+AC_CHECK_PROG([BISON], [bison -y], [yes], [no])
+AS_IF([test "x$BISON" = "xno"], [AC_MSG_ERROR([bison not found])])
+
+AC_ARG_VAR([FLEX], [flex command])
+AC_CHECK_PROG([FLEX], [flex -y], [yes], [no])
+AS_IF([test "x$FLEX" = "xno"], [AC_MSG_ERROR([flex not found])])
if test "$GXX" = yes ; then
ac_gcc_version=`echo __GNUC__ | $CC -E - | grep -v ^\#`
@@ -169,7 +176,7 @@ enable system Boehm garbage collector)]
fi
])
-OPTIONS="-D_FILE_OFFSET_BITS=64 "
+OPTIONS="-D_FILE_OFFSET_BIS=64 "
GCLIB=
GCPPLIB=
INCL="-I."
@@ -259,8 +266,8 @@ AC_SUBST(OPTIONS)
AC_SUBST(GLEW)
# Checks for libraries.
-AC_SEARCH_LIBS([lgamma],[m c],,
-AC_MSG_ERROR([*** Please install libm on your system ***]))
+#AC_SEARCH_LIBS([lgamma],[m c],,
+#AC_MSG_ERROR([*** Please install libm on your system ***]))
AC_CHECK_LIB([z], [deflate],,
AC_MSG_ERROR([*** Please install libz or zlib-devel on your system ***]))