summaryrefslogtreecommitdiff
path: root/graphics/asymptote/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/asymptote/configure.ac')
-rw-r--r--graphics/asymptote/configure.ac16
1 files changed, 8 insertions, 8 deletions
diff --git a/graphics/asymptote/configure.ac b/graphics/asymptote/configure.ac
index 3fe1598181..7e6dd1aaa1 100644
--- a/graphics/asymptote/configure.ac
+++ b/graphics/asymptote/configure.ac
@@ -3,10 +3,11 @@
# this file.
AC_PREREQ(2)
-AC_INIT([Asymptote],[2.89],[https://github.com/vectorgraphics/asymptote/issues])
+AC_INIT([Asymptote],[2.90],[https://github.com/vectorgraphics/asymptote/issues])
VERSION=$PACKAGE_VERSION
AC_SUBST(VERSION)
m4_include([ax_pthread.m4])
+m4_include([pkg.m4])
AC_C_BIGENDIAN
AC_CANONICAL_HOST
@@ -322,18 +323,17 @@ AC_CHECK_HEADERS(editline/readline.h)
])
AC_DEFUN([PKG_CONFIG],[
-ifdef([PKG_CHECK_MODULES],$1="$2 "`pkg-config --silence-errors $3 $4`,)
+ifdef([PKG_CHECK_MODULES],$1="$2 "`pkg-config --silence-errors $3 $4 || echo`,$1="$2 ")
])
AC_DEFUN([CHECK_LIB_STATIC],[
-PKG_FLAGS=""
PKG_CONFIG(PKG_FLAGS,,--libs,$1)
-if test "x$PKG_FLAGS" == "x"; then
+if test "x$PKG_FLAGS" == "x "; then
PKG_FLAGS=-l"$2"
-echo Will try linking with $PKG_FLAGS
+echo will try linking with $PKG_FLAGS
fi
LDFLAGS_SAVE=$LDFLAGS
-LDFLAGS="$LDFLAGS ""$STATIC ""$PKG_FLAGS ""$DYNAMIC "
+LDFLAGS="$LDFLAGS "$STATIC"$PKG_FLAGS "$DYNAMIC
AC_CHECK_LIB($2,$3,AC_DEFINE($4,1,DEFINE_LIB($2)),
if test "x$enable_static" = "xyes"; then
[
@@ -344,7 +344,7 @@ AC_CHECK_LIB($2,$3,AC_DEFINE($4,1,DEFINE_LIB($2)),
[
LDFLAGS=$LDFLAGS_SAVE
$5
-])
+],$PKG_FLAGS)
]
else
[
@@ -352,7 +352,7 @@ LDFLAGS=$LDFLAGS_SAVE
$5
]
fi
-)]
+,$PKG_FLAGS)]
)
if test "x$enable_readline" != "xno"; then