summaryrefslogtreecommitdiff
path: root/graphics/asymptote/LspCpp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/asymptote/LspCpp/CMakeLists.txt')
-rw-r--r--graphics/asymptote/LspCpp/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/graphics/asymptote/LspCpp/CMakeLists.txt b/graphics/asymptote/LspCpp/CMakeLists.txt
index ed420b2955..fe35bfcb8c 100644
--- a/graphics/asymptote/LspCpp/CMakeLists.txt
+++ b/graphics/asymptote/LspCpp/CMakeLists.txt
@@ -197,7 +197,7 @@ if(USE_SYSTEM_RAPIDJSON)
endif()
endif()
if(NOT RapidJSON_FOUND)
- if(EXISTS "${CMAKE_SOURCE_DIR}/third_party/rapidjson/include")
+ if(EXISTS "${PROJECT_SOURCE_DIR}/third_party/rapidjson/include")
message(STATUS "Using local RapidJSON")
set(RapidJSON_INCLUDE_DIRS third_party/rapidjson/include)
else()
@@ -227,7 +227,6 @@ target_include_directories(lspcpp
target_link_libraries(lspcpp PUBLIC network-uri ${Boost_LIBRARIES})
set(LSPCPP_THIRD_PARTY_DIR_LIST
- ${LSPCPP_THIRD_PARTY_DIR}/threadpool
${LSPCPP_THIRD_PARTY_DIR}/utfcpp/source
)