summaryrefslogtreecommitdiff
path: root/fonts/utilities/ps2pk/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'fonts/utilities/ps2pk/configure.ac')
-rw-r--r--fonts/utilities/ps2pk/configure.ac42
1 files changed, 42 insertions, 0 deletions
diff --git a/fonts/utilities/ps2pk/configure.ac b/fonts/utilities/ps2pk/configure.ac
new file mode 100644
index 0000000000..9d0f79dc68
--- /dev/null
+++ b/fonts/utilities/ps2pk/configure.ac
@@ -0,0 +1,42 @@
+dnl Process this file with autoconf to produce a configure script.
+dnl
+dnl Copyright 2009-2016 Peter Breitenlohner <tex-live@tug.org>
+dnl
+dnl This file is free software; the copyright holder
+dnl gives unlimited permission to copy and/or distribute it,
+dnl with or without modifications, as long as this notice is preserved.
+dnl
+AC_INIT([ps2pkm (TeX Live)], [1.8], [tex-k@tug.org])
+AC_PREREQ([2.65])
+AC_CONFIG_SRCDIR([arith.c])
+AC_CONFIG_AUX_DIR([../../build-aux])
+AC_CONFIG_MACRO_DIR([../../m4])
+
+dnl Common code for all programs using libkpathsea.
+KPSE_COMMON([ps2pkm], [no-define])
+
+AC_SEARCH_LIBS([pow], [m])
+
+dnl Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([fcntl.h])
+
+dnl Checks for types.
+AC_TYPE_INT32_T
+AC_TYPE_INTPTR_T
+AC_TYPE_UINT32_T
+
+dnl Checks for library functions.
+AC_FUNC_VPRINTF
+AC_CHECK_FUNCS([memset])
+
+AC_CONFIG_HEADERS([c-auto.h:c-auto.in])
+
+dnl For tests
+AC_CHECK_PROGS([KPSEWHICH], [kpsewhich], [false])
+
+KPSE_KPATHSEA_FLAGS
+
+AC_CONFIG_FILES([Makefile])
+
+AC_OUTPUT