summaryrefslogtreecommitdiff
path: root/dviware/dvisvgm/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'dviware/dvisvgm/tests/Makefile.am')
-rw-r--r--dviware/dvisvgm/tests/Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/dviware/dvisvgm/tests/Makefile.am b/dviware/dvisvgm/tests/Makefile.am
index 33d6fca2a5..002e7e82bf 100644
--- a/dviware/dvisvgm/tests/Makefile.am
+++ b/dviware/dvisvgm/tests/Makefile.am
@@ -16,6 +16,7 @@ EXTRA_DIST = gtest/LICENSE \
gtest/src/gtest-filepath.cc \
gtest/src/gtest-internal-inl.h \
gtest/src/gtest_main.cc \
+ gtest/src/gtest-matchers.cc \
gtest/src/gtest-port.cc \
gtest/src/gtest-printers.cc \
gtest/src/gtest-test-part.cc \
@@ -117,12 +118,6 @@ CommandLineTest_SOURCES = CommandLineTest.cpp testutil.hpp
CommandLineTest_CPPFLAGS = -I$(dvisvgm_srcdir)/tests/gtest/include $(LIBS_CFLAGS)
CommandLineTest_LDADD = $(TESTLIBS)
-TESTS += CRC32Test
-check_PROGRAMS += CRC32Test
-CRC32Test_SOURCES = CRC32Test.cpp testutil.hpp
-CRC32Test_CPPFLAGS = -I$(dvisvgm_srcdir)/tests/gtest/include $(LIBS_CFLAGS)
-CRC32Test_LDADD = $(TESTLIBS)
-
TESTS += DependencyGraphTest
check_PROGRAMS += DependencyGraphTest
DependencyGraphTest_SOURCES = DependencyGraphTest.cpp testutil.hpp
@@ -147,6 +142,12 @@ DvisvgmSpecialTest_SOURCES = DvisvgmSpecialTest.cpp testutil.hpp
DvisvgmSpecialTest_CPPFLAGS = -I$(dvisvgm_srcdir)/tests/gtest/include $(LIBS_CFLAGS)
DvisvgmSpecialTest_LDADD = $(TESTLIBS)
+TESTS += EllipticalArcTest
+check_PROGRAMS += EllipticalArcTest
+EllipticalArcTest_SOURCES = EllipticalArcTest.cpp testutil.hpp
+EllipticalArcTest_CPPFLAGS = -I$(dvisvgm_srcdir)/tests/gtest/include $(LIBS_CFLAGS)
+EllipticalArcTest_LDADD = $(TESTLIBS)
+
TESTS += EmSpecialTest
check_PROGRAMS += EmSpecialTest
EmSpecialTest_SOURCES = EmSpecialTest.cpp testutil.hpp