summaryrefslogtreecommitdiff
path: root/dviware/dvi2bitmap/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'dviware/dvi2bitmap/doc/Makefile.am')
-rw-r--r--dviware/dvi2bitmap/doc/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/dviware/dvi2bitmap/doc/Makefile.am b/dviware/dvi2bitmap/doc/Makefile.am
new file mode 100644
index 0000000000..15f3868255
--- /dev/null
+++ b/dviware/dvi2bitmap/doc/Makefile.am
@@ -0,0 +1,29 @@
+## Process this file with automake to produce Makefile.in
+
+XSLTPROC=@XSLTPROC@
+
+XML2HTML=xml2html
+include xml2html/Makefile
+
+
+doc.html: doc.xhtml style.css
+# ReleaseNotes.xml is for pre-1.0 releases
+doc.xhtml: doc.xml doc.img version.ent
+
+doc-m.tex: doc.xml
+ $(XSLTPROC) --stringparam target m xml2html/structure.xslt doc.xml | \
+ sed -e 's/&lt;/</g' -e 's/&gt;/>/g' -e 's/&amp;/\&/g' >doc-m.tex
+doc.img: doc-m.tex
+ rm -Rf doc.img; mkdir doc.img
+ cp doc-m.tex doc.img
+ cd doc.img; tex doc-m
+ cd doc.img; ../../dvi2bitmap --magnification=3 --scaledown=3 --output-type=gif doc-m
+
+style.css:
+ cp ../html/style.css .
+
+version.ent: Makefile
+ rm -f version.ent
+ echo '<!ENTITY version "$(PACKAGE_VERSION)">' >version.ent
+
+CLEANFILES=doc.html doc.xhtml doc-m.tex style.css