summaryrefslogtreecommitdiff
path: root/support/texlab/crates/jsonrpc/Cargo.toml
diff options
context:
space:
mode:
authorNorbert Preining <norbert@preining.info>2020-05-28 03:03:21 +0000
committerNorbert Preining <norbert@preining.info>2020-05-28 03:03:21 +0000
commit745892fbddea56040139108277e728b53fd8fc11 (patch)
tree15e55e299b38fccdabce8364f1fbf4f02ef37994 /support/texlab/crates/jsonrpc/Cargo.toml
parent195ca7e0c377d83455867bdd8e409d4e1cf024ea (diff)
CTAN sync 202005280303
Diffstat (limited to 'support/texlab/crates/jsonrpc/Cargo.toml')
-rw-r--r--support/texlab/crates/jsonrpc/Cargo.toml17
1 files changed, 10 insertions, 7 deletions
diff --git a/support/texlab/crates/jsonrpc/Cargo.toml b/support/texlab/crates/jsonrpc/Cargo.toml
index d806759f3f..cae7107ae1 100644
--- a/support/texlab/crates/jsonrpc/Cargo.toml
+++ b/support/texlab/crates/jsonrpc/Cargo.toml
@@ -2,16 +2,19 @@
name = "jsonrpc"
version = "0.1.0"
authors = [
- "Eric Förster <efoerster@users.noreply.github.com>",
- "Patrick Förster <pfoerster@users.noreply.github.com>"]
+ "Eric Förster <eric.foerster@outlook.com>",
+ "Patrick Förster <patrick.foerster@outlook.de>"]
edition = "2018"
+[lib]
+doctest = false
+
[dependencies]
+async-trait = "0.1"
chashmap = "2.2"
-futures-boxed = { path = "../futures_boxed" }
-futures-preview = "0.3.0-alpha.18"
-log = "0.4.6"
-tokio = "0.2.0-alpha.6"
-serde = { version = "1.0", features = ["derive"] }
+futures = "0.3"
+log = "0.4"
+serde = { version = "1.0", features = ["derive", "rc"] }
serde_json = "1.0"
serde_repr = "0.1"
+tokio = { version = "0.2", features = ["rt-core"] }